Adobe Experience Manager Connector Troubleshooting

The Adobe Experience Manager connector has a custom log in the Logs folder under the installation target A Target is a "pointer" to a specific instance of a search application, such as Elasticsearch. - (A Search application instance has one or more indexes) location that tracks Jira issues and is useful for troubleshooting.

Crawling Large Content

When large content is crawled by the connector, the following error can occur:

"The query read or traversed more than 100000 nodes. To avoid affecting other tasks, processing was stopped."

Cause

Queries used by Adobe Experience Manager connector mostly traverse the direct children of a node for each query.

The only exception is a query executed at the beginning of each crawl to retrieve all the permissions defined anywhere in the sub-tree to crawl.

If the content contains lots of nodes, the error above may happen.

Solution

To fix the issue, do the following:

  1. change the 'LimitReads' to an appropriate value. Use the information at the following URL (insert your Adobe Experience base URL into the address): http://<Adobe Experience Manager base URL>/system/console/jmx/org.apache.jackrabbit.oak%3Aname%3Dsettings%2Ctype%3DQueryEngineSettings

Users are not being updated in ACL Test Bench security sync

Cause

There is a caching mechanism in the BA Insight SDK/Connector which will make the connector return the cached result if called twice in a row.

Solution

You must recycle the application pool before running the ACL test.

For any other issues, see Connectors FAQs.