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Introduction
Connect Designer lets you create and design print documents, web pages and emails in one
tool. Every aspect of a document can be easily personalized thanks to its feature-rich and user-
friendly interface.

The file format of the templates is HTML, the main markup language for web pages and e-mail
messages. When exploring the user interface you will see several items that reveal this
underlying technology. You will be able to work with the application without knowing HTML, but
for users who are advanced in HTML and related technologies and standards like JavaScript
and Cascading Style Sheets, the user interface does include the appropriate features.

This tutorial will teach you to create a new basic invoice from scratch. It will explain common
techniques that are applicable to other document types too. But there is more to learn. Please
visit learn.objectiflune.com and help.objectiflune.com to discover new ways and enhance your
skills.

This walkthrough is meant to be used with OL Connect Designer 2020.1 and later versions.

Template requirements
Here are the requirements for the invoice template that needs to be created:

l The template contains a letterhead. Which color it has, depends on the hobby of the
receiver: green for skating, purple for skiing.

l The general invoice information, like the invoice number and the due date, should be
printed at the top, under the letterhead.

l The invoice data has to be printed in a table. The table should contain a transport line if it
runs over two or more pages. The pages should be numbered.

l The company has several offices. The sender’s address should be the office that is
nearest to the receiver of the invoice.

l To fill any remaining white space a picture should be printed. Which picture is printed
depends on the hobby of the receiver. If no white space remains, the picture should not be
printed.

The generated invoice will look similar to this picture:
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Creating a template
The exercises in this lesson introduce the concepts of sections, content and formatting. You will
also learn how to navigate the content.

1. Creating a template
In this exercise you will learn how to create a new document for print. A Print template can be
printed to a printer, to a file, or it can be attached to an email designed in Connect Designer.

1. Launch the Designer application by double-clicking the application icon.
2. Choose File > New > Template > Print Template and click Next, or click Create a New

Template in the Welcome screen and choose Print. The New Print Template wizard is
shown.
The dialog lets you enter parameters for the new document, which includes its page size,
the page margins and the number of sections. A section contains one or more pages. Text
will flow automatically from one page to the next.

3. Make the following settings:

l Page size: Letter
l Margin Top: 1.4in
l Margin Left: 1.6in
l Margin Bottom: 1.2in
l Margin Right 0.8in

4. Click Finish. The new document is shown in the main area of the user interface.

5. On the Resources pane at the left, expand the Context, and then the Print folder. Right-
click Section 1 and rename the section to Invoice.

6. To save the document, choose File > Save As. The Save Template dialog box displays.
7. Navigate to a folder (the folder where you unzipped the Walkthrough files, for example),

enterMy OLSG Invoice.OL-template in the File name field and then click Save.
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2. Importing images
In this exercise you will learn how to import images into a template. Images can be static
elements or they can be dynamically replaced by scripts based on a data field. They can also
be used as a dynamic element to fill white space, as you will see in a later exercise.

1. In case the Resources pane is not shown, chooseWindow > Show View > Resources.
2. Locate the images folder provided with this tutorial.
3. Drag OLSG_letterhead-green.pdf to the Images folder in the Resources pane.

3. Adding a Virtual Stationery background
In this exercise you will learn how to set a PDF image as a background to emulate pre-printed
paper. After specifying a so called "virtual stationery image" you can preview the pre-printed
media and place the content in the correct position. The image will be repeated for all pages
that use this media.

To set a PDF as media:

1. Locate the file OLSG_letterhead-green.pdf in the Images folder on the Resources pane
(the image was added in the previous exercise).

2. Drag OLSG_letterhead-green.pdf to the Media 1 entry in the Media folder on the
Resources pane. The first page in the PDF will be set as the image for the front side of the
media.
After adding the image to the Media you will see that the image appears in the
background of the page(s).

What if you dropped the wrong PDF on the Media or want to change it? The Media properties
dialog allows you to delete a PDF file from a Media. It also lets you select an image for both the
front and back of the Media and specify the position of the image.
To open the dialog, right-click the Media 1 entry and select Virtual Stationery from the shortcut
menu.
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Note

By default, Media backgrounds are omitted from the output (because in the end, the pre-
printed paper will have this imagery). In case you are printing on blank paper you could
print this background image together with the document by selecting the Print Virtual
Stationery option in the Advanced section of the Print Wizard interface or in an Output
Creation Preset.

4. Adding text and applying basic
formatting to it
In Connect Designer every print section consists of a main text flow. This is the area defined by
the page size and margins. The margin guides are shown in light blue.

1. Place the cursor at the start of the document.
2. Type INVOICE.
3. Select the word INVOICE and change the style from Paragraph to Heading 1 using the

Formatting toolbar.
4. Press Enter and type Terms and Conditions on the next line. Change the style to

Heading 3.
5. Press Enter and then click the Insert Lorem Ipsum toolbar button to enter dummy text.

6. Select one word in the dummy text and use the Bold toolbar button to make it bold.
7. Select the paragraph
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Alternatively you could copy-paste text from a text processor, such as MS Word. Basic style
characteristics specified in MS Word travel with the content to Connect Designer. Formatting
options like bold, italic and formats like Heading 1, Heading 2 are maintained.

5. Exploring the document
In this exercise you will learn how to explore and quickly select elements on the page using the
Outline pane and the breadcrumbs. The Outline pane at the left shows a hierarchical tree
structure of the pages and their elements. Advanced users will refer to this as the HTML
Document Object Model or DOM.

1. The Outline pane is located in the upper left area next to the main editor. If the Outline
pane isn’t visible, chooseWindow > Show View > Outline.
In this example the Outline pane shows two headings and one paragraph. The
subheadings are marked with <h1> and <h3> and the paragraph is represented by the
<p> entry in the tree.
A <p> element defines a paragraph in HTML. Other common HTML elements are:

l h1 through h6 (headings)
l img (image)
l table
l tr (table rows)
l td (table data or table cells)
l span (a piece of styled text)
l div (a box).

2. Click the <p> element. The main document window jumps to that paragraph and shows
an outline around its contents. The paragraph is now selected and you can see a p in the
blue bar located under the title bar of the document. This line is referred to as the
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breadcrumbs.

3. Click on INVOICE. Note that both the Outline pane and the breadcrumbs are updated to
show that the currently selected element is h1.

4. Click on the word under Terms and Conditions that you’ve bolded. The breadcrumbs
show that the selected, bold word is located inside a paragraph: p > b.

5. Now click on the p in the breadcrumbs. Note that the paragraph gets selected in both the
text and the Outline pane.

6. With the paragraph still selected, select font-size 9pt in the Formatting toolbar to reduce
the size of the Lorem ipsum text.
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Adding personalization
To create any personalized document, you need data about the recipients. Typically such data
include fields like the first name, last name, email address, job title etc. The exercises in this
chapter show how to load data and demonstrate various techniques to add data fields to the
page.

1. Loading data
In this exercise you will learn how to load data by opening a data mapping configuration. It is
also possible to open a data file or database in the Designer, but transactional data – such as
line items in an invoice – can’t be imported in the Designer directly. That's why we need a data
mapping configuration.

1. Go to theWelcome screen by clicking the Home icon at the top right.
2. On the right, under Create/Open, click Open File. Change the file type to DataMapper

files (*.OL-datamapper).
3. Select the data mapping configuration provided with this tutorial:OLSG-invoice.OL-

datamapper, or a data mapping configuration made by you with a DataMapper
walkthrough. The DataMapper workspace is shown.

4. Toggle back to the Designer perspective by clicking the My OLSG Invoice.OL-template
tab at the top of the workspace.

5. The Data Model pane now shows the data model and the data of the first record in
OLSG-invoice.OL-datamapper. If not, hit the Synchronize model button in the Data
Model pane to update the Data Model to the current data mapping configuration.
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6. Use the browse buttons at the top of the Value column to browse through the imported
data.

7. Scroll down in the Data Model pane to see the detail table and browse through its detail
records.

2. Adding a table to hold the address and
invoice information
In this exercise, you will learn how to add a table that functions as a container for the address of
the client and the invoice information. The table, which in this case is placed in the main text
flow, will have two columns: the left column is for the address data and the one on the right is
for invoice information.

The following image shows the end result.

To add a table to the main text flow:

1. Return to the invoice template. Create a new paragraph after the INVOICE heading by
pressing the Enter key after the last character of the heading.
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2. Select Insert > Table > Standard… from the Menu or click the Insert Table icon on the
toolbar. The Insert Table dialog appears. This dialog lets you configure the new table.

3. Make the following settings on the first page of the Insert Table wizard:

l ID: invoice-info
l Header Rows: 0
l Body Rows: 1
l Footer Rows: 0
l Columns: 2

4. Use the Location drop-down to select Before element as the insertion point. This will
insert the table before the new paragraph.
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5. Click Next and select the table style at the top left, which does not have any borders or
background colors. The table will take up the maximum available space horizontally and
runs between the left and right margin guides.

6. Click Finish to insert the table.
7. As the table doesn’t have any borders or background it blends into the page. Click the

Show Edges button on the toolbar to reveal its position. The table shows a non-printing
green border.

3. Adding the invoice information
In this exercise you will add the invoice information like the invoice number, due date and
invoice total to the table. You will do this by dragging the data fields into the template.

1. Place the cursor in the right table cell of the initial table.
2. Type the following text:

l Invoice Number: (press Enter twice)
l Payment Due: (press Enter twice)
l Invoice Total: (press Enter once)

3. Now, to add the variable data, drag the data fields InvNumber, DueDate and InvTotal
one by one from the Data Model pane into the table, after the respective label. To push
them to the next line, place the cursor before the first @, hold the Shift key and press the
Enter key once.

4. Take a look at the Scripts pane: three new scripts have been added.
When you drag a data field from the Data Model pane to anywhere in the template, a
placeholder is inserted at the cursor position and a script is added to the Scripts pane.
The script's selector is the class of the placeholder (actually of the span that contains the
placeholder). Click a placeholder; its class will become visible on the Attributes pane.
When viewing the document in Preview mode (or when generating output), the scripts are
executed, by which the placeholders get replaced with the value of the data field.

5. Select the text of each label and click the Bold icon on the toolbar to set the font-weight
for the selected label.
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6. Click the Preview tab along the bottom of the main editor to view the merged template.

4. Adding the address
In this exercise you will learn how to add variable data, not by dragging data fields to the
document but by using the Text Script wizard instead. The Text Script wizard concatenates
multiple data fields into the full multi-line address and it can add a prefix and/or suffix to each
data field. One of the big advantages of using a Text Script wizard is that it facilitates skipping
empty lines when data fields are empty.

1. Type the following text in the first table cell: Issued to.
2. Select 'Issued to' and click the Bold icon in the Formatting toolbar.
3. Click after 'Issued to', press Enter two times and type@customer@.

4. Create a new text script entry: select @customer@, right-click the selection and select
Text Script....
A script entry is added to the Scripts pane and opened in the Edit Script dialog. The Find
text field has the text@customer@.

5. Change the name of the script so that it clearly describes the purpose of the script (e.g.
Set Address).

6. Change the selector type to Selector and Text.
7. In the Selector field, type #invoice-info. #id refers to the element with the specified ID,

which in this case is the ID of the table.

Note

By default, a Text Script scans the entire template for placeholders (such as a data
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field name surrounded by the “@” signs) and replaces them by the value of a data
field. In larger and more complex documents, this has an impact on the output
performance. The option Selector and Text combines the text of the placeholder
with a selector that identifies the HTML element in which the placeholder is located.
This reduces the scope of the search and thereby speeds up the output.

8. The Text Script wizard is able to combine data from multiple data fields. Each field is
placed on its own line in the wizard. New lines can be added by clicking the Plus sign
next to the table or simply by clicking on the next empty line.
The Prefix and Suffix fields add text to the data of each field.
Important!When a data field is empty the respective line is skipped including its prefix
and suffix.

Add lines for the following fields and set the respective suffix text.

Prefix Field Suffix

Company <br/> (adds a line break)

Title one space

FirstName one space

LastName <br/>

Address1

<br/> City , (comma, then space)

State

one space ZipCode <br/>

Country

Tip

For two spaces to be used as a prefix or suffix, enter two non-breaking space
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characters (represented by the HTML entity: &nbsp;) instead of two regular spaces.
In HTML by default multiple regular spaces will be collapsed to a single space
character.

9. At the bottom of the dialog, click Options and verify that the Insert Method is HTML.
10. Click OK. The name of the script will be shown in the Scripts pane.
11. Toggle to the Preview mode and use the browse buttons of the Data Model pane to

navigate through the records. The address block should look like this:

Company
Title First name Last Name
Address1
City, State Zip code
COUNTRY

5. Changing the date format
Predefined date format
Dates added by a Text Script have a medium date formatting by default. In this exercise you’ll
change the formatting of the date to another predefined date format.

1. In the Scripts pane, double-click the script that inserts the date. The Edit Script dialog
appears.
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Tip

Hovering over the name of a script in the Scripts pane highlights the content that is
affected by it. This makes it easy to find the correct script.

2. Select Long Date in the Format column and click OK.

Note

The format options in the Text Script wizard depend on the type of data field. The field
type is defined in the DataMapper workflow. Supported field types are: String, HTML
String, Boolean, Date, Integer, Float, Currency and Date.

Locale
The actual date format also depends on the locale, set for the document.

1. Choose: Edit > Locale… The Locale dialog appears. By default the template makes use
of the system locale.
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2. Change the Use field to Explicit Locale and select a different entry from the Locale drop-
down.

3. Click OK to store the new setting and see its effect.

Tip

The Data field drop-down in the Locale dialog gives you the possibility to use a variable
locale, that is, if your data contains a field that holds a locale code. The locale will be
record-specific in this case. Both language codes (en, fr etc.) and language-country
codes (en-CA, fr-FRA) are valid locales.
Yet another option is to use a runtime parameter. Parameters can be defined in the
template and filled with a value in Workflow.

Custom date
Let’s say you prefer a custom format for the date. It is perfectly possible to use a custom format.
Reopen the script (repeat step 1 under Predefined date format).

1. Click in the Format field and select Custom pattern.
2. Type yyyy-MM-dd and click OK. Now the date looks as follows: 2016-07-01.

6. Aligning text in table cells
The texts in the two table cells are not aligned at the same height. This is because the text is
aligned vertically to the middle of the cell. Changing the alignment of the text in the table cells
will make the invoice prettier.

Page 21



1. Switch to the Design tab.
2. Select the text in the right table cell. Then click the Align Right icon in the toolbar.
3. Select the table as a whole. You can do this by clicking table #invoice-info in the

breadcrumbs.
4. Select Format > Table Cell…
5. On the Cell tab, set the Vertical Align drop-down to top.
6. Click OK. The text in both table cells will now be aligned to the top of the cell.

7. Switch to the Preview tab to see the result.
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Adding the dynamic invoice data
The Dynamic table feature provides an easy way to lay out rows and columns for line item
information such as the description of a product, the unit price, total price, quantity etc. Table
rows are automatically inserted based on the number of rows in a detail table. Once the table
reaches the bottom of the page a new page is inserted automatically. The invoice will continue
on the next page. Headers and footers can be repeated across pages and subtotals, transport
lines and the invoice’s total can be added automatically.

In this exercise you’ll learn how to insert a dynamic table to lay out the information of a detail
table stored in the data set.

1. Adding the dynamic table
1. Toggle to the Design mode and place the cursor at the beginning of the heading 'Terms

and Conditions'.
2. Choose: Insert > Table > Dynamic Table... The Insert Dynamic Table dialog appears.
3. Change the value of the ID field to: invoice-data.
4. Make sure that the Detail table field reads products. This is the detail table in the data

that holds the invoice line items.
5. From the Location drop-down, choose Before element. This causes the table to be

inserted directly before the level 3 heading (h3).
6. Click Next. The Dynamic Table Builder is shown.

It contains one 'row' which is associated to the selected detail table. The row will be
repeated in the output (or in Preview mode) as many times as necessary to display all the
records in the associated detail table.
The 'fields' - cells in the table - correspond to data fields in the detail table.

7. Delete the #Shipped and #BackOrder fields by clicking on the red cross. The following
fields should be listed:

l ProdNumber
l Description
l UnitPrice
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l Shipped
l Total

The fields will appear in the table in the order in which they are listed here. To rearrange
them, you can drag and drop them by clicking to the left of a field.

8. Without currency signs the values in the Unit Price and Total columns will look better.
Change the Format for these fields to Currency No Symbol.

9. Note how the alignment is set for text in different kinds of fields: text is left-aligned,
amounts in currency fields are right-aligned and numbers are centred.

10. Click Next. The Dynamic Table Options page is shown. The options on this page let you
add subtotals to the footer and transport lines (in case the table runs across multiple
pages).

11. Check the Calculate Subtotals item.
12. Verify that Total is selected as the data field that will be used to calculate the subtotals

and totals.
13. Check both Show subtotal lines options to have subtotals shown before and after page

breaks.
14. Click Next. The predefined table styles are shown.
15. Select the 6th table style (the second from the top right) and click Finish to insert the

table.
How to further style the table is demonstrated later in this walkthrough.
The table is inserted at the current cursor position. It has a column for each of the selected
data fields. The cells in the body table row, between the header and footer rows, show the
placeholders of the respective data fields (surrounded by @ signs).
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Tip

Click the Show Edges button on the toolbar to show the edges of the table with thin
green lines. These lines are visible in Preview mode, but will not be printed.

16. Toggle to Previewmode. You will see that the body table row is repeated for each detail
record and that the placeholders are replaced with the corresponding data values.

Note that you will see only one of the subtotals rows on each page in output and in
Preview mode. The bottom footer row is only shown on the last page. The row above it is
shown on all other pages, if the table runs over multiple pages.

2. Adding labels and rows
At this point the table shows the basic information of the invoice line items. In this exercise
you’ll learn how to add additional rows and information to this table.

To add a label to the subtotals in the footer:

1. In Design mode, place the cursor in the cell next to the @Total@ cell in the first row of the
footer of the table. Type Subtotal.

2. Do the same in the bottom footer row.

Now add additional rows for the tax and invoice total:

1. Right-click one of the cells in the bottom row and choose Row > Insert Below from the
shortcut menu. Repeat this to add a second row.
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2. On the Outline pane, click on the second to last footer row (the third <tr> in <tfoot>).
3. On the Attributes pane, change Show Row to: At end of table. This prevents that a row

is shown on every page if the table runs over multiple pages.
4. Repeat the previous step for the last footer row.
5. Place the cursor below the Subtotal cell and type: VAT.
6. Move the cursor one row down and type: Total inc VAT.
7. Locate the InvTaxTotal data field in the Data model panel and drag this field into the cell

next to the VAT cell.
8. Drop the InvTotal data field in the last table cell of the table.

Now, in Preview mode the table will look like this:
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Formatting the Dynamic Table
This chapter explains how to format a Dynamic Table. You will not only change the text and
text alignment, but also change the column widths, borders and background colors.

Note

These changes are best made in Design mode.

1. Formatting text and currencies
In this exercise you will change some labels, text alignments and the formatting of amounts of
money. Formatting text in a Dynamic Table is no different from how it is done in a Standard
Table.

1. The headers of the columns contain the name of the respective data fields. In Design
mode, change them to proper headings: change ProdNumber to Number, UnitPrice to
Unit Price and Shipped to Quantity.

2. Select the first Subtotal label and click the Bold icon on the toolbar. Then set the text
alignment of the cell to the right by clicking the Align Right icon on the formatting toolbar.

3. Do the same with the other labels in the footer: Sutbtotal, VAT and Total inc VAT.
4. Toggle to Previewmode to verify your changes. The table should look like the image

below:
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We have already set the format for the Unit Price and Total fields when adding the table. To
change the formatting of line items and subtotals after adding the table:

1. In Design mode, click on the cell.
2. On the Attributes pane, select the desired format from the Format drop-down.

If you would want to change the formatting of values outside line items and subtotals, such as
the VAT and Total inc VAT fields in this table, here is how to do that:

1. Double-click the respective script on the Scripts pane to open the Edit Script dialog.
2. Open the drop-down list in the Format column and select Currency No Symbol.

2. Changing column widths
The product descriptions are rather long. It would be best if most of them would fit on a single
line. This can be achieved by changing the column widths:

1. In Design mode, hover the mouse between the Number and Description columns. The
cursor changes to a column resizer icon.

2. Click and drag the column separator to the left. Then resize the other columns, from right
to left.

3. Toggle to Previewmode to see the effect.

4. The widths could be improved in columns where the actual data are less wide than the
placeholders. Toggle to Design mode, click in the field that holds the Number label and
on the Attributes pane, in the Geometry section, setWidth to a smaller percentage, e.g.
10%.
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5. Toggle to Preview mode and back to Design mode, and change the widths of cells in the
header row until all labels and (most) line items fit on a single line.

6. To ensure that the widths can't be changed accidentally, we will disable the option to
resize the table. Select the table: click somewhere in the table, and then click on table
#invoice-data.table--light in the breadcrumbs.

7. On the Attributes pane, in the Other section, uncheck the option Allow Resizing. (You
may have to scroll down in the Attributes pane to see this option.)

3. Using the Formatting dialog
In this exercise you will learn how to use the Table Cell Formatting dialog. The next exercise
shows how to use the Stylesheets dialog.

1. In Design mode, place the cursor in the first cell of the header row. Press the Shift key
and click the last cell in this row. The cells of the header row are now selected.

2. Right-click one of the selected cells and select Cell… (note the dots) from the contextual
menu. The Table Cell Formatting dialog appears.

3. Click the Border tab.
4. Deselect the Same For All Sides option and make the following settings for the Top

border:

l Width: 1pt
l Style: solid

5. Click the small square next to the Color field. The Color dialog appears. Under RGB,
enter:
R: 144, G: 144, B: 144.

6. Click OK to close the Color dialog.
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7. Click OK again to apply the border settings to the selected cells.

8. Select the cells in both Subtotal rows and open the Table Cell Formatting dialog.
9. Click the Background tab. Click the small square next to the Color field. The Color

dialog appears.
10. Under RGB, enter: R: 230, G: 230, B: 230. Click OK to close the Color dialog and OK

again to close the Table Cell Formatting dialog. The table now looks like this:

4. Using the Stylesheets dialog
Horizontal lines make it easier to read the data and they make the table look better. This
exercise shows how to change borders and background colors to table cells with CSS
(Cascading Style Sheets), via the Stylesheets dialog.

1. Choose Edit > Stylesheets…, to make the Stylesheets dialog appear.
2. From the Context drop-down, choose Print, to make the styles apply to Print sections

only.
3. Click the Plus icon to create a new style rule.

4. In the dialog that appears, type td in the Selector field. The selector defines to which
elements in the document the rule applies. By stating td the rule applies to all table cells.
In HTML, a table data cell is a <td>.

5. Click the Border tab.
6. Deselect the Same For All Sides option and make the following settings for the Top

border:

l Width: 1pt
l Style: solid
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7. Click the small square next to the Color field. The Color dialog appears. Under RGB,
enter:
R: 144, G: 144, B: 144.

8. Click OK to close the Color dialog.

9. Click OK to close the rule editor.
The top part of the Stylesheets dialog lists selectors (up to now there’s only one: td) and
the preview in the bottom part lists all style rules for the selected selector. In the style rule
that you’ve just made, “border-top” is the CSS property, and “1pt solid rgb(144, 144, 144)”
is the value assigned to that property.

10. Click Save to close the Stylesheets dialog.
11. Toggle to Previewmode and look carefully at both tables in the template: the standard

table with the invoice and address information and the Dynamic Table.

As you can see, the newly added style rules don’t just affect cells in the Dynamic Table.
They also apply to the table with the invoice information. This is because the selector
selects all cells in all tables. So, the selector has to be more specific.

12. Reopen the Stylesheets dialog and select the context: Print.
13. Select td and click the Edit button (with the blue pencil).
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14. Change the selector to #invoice-data td. Save the settings. Now, the style rule only
applies to table cells inside an element that has the ID: invoice-data – which is the
Dynamic Table.

15. Create a new rule-set: click the Add button, type the selector #invoice-data tfoot and on
the Type tab, check Bold. This bolds all text in all footer rows of the Dynamic Table.

Tip

The options in the Rule editor represent the most frequently used CSS properties. If
a property is not available here, click the Advanced button. In Advanced mode you
can add a style rule by typing a CSS property (at the left) and its value (at the right).

16. Save the settings. In Preview mode, the table should now look like this:

17. A different background color and text color will make the total amount of the invoice stand
out. Coloring two cells with one style rule is easy, when they have the same class.
In Design mode, click in the cell that contains the text Total inc VAT and use the
breadcrumbs or the Outline pane to select the cell (td).

18. On the Attributes pane, in the Class field, type invtotal.
19. Repeat the previous two steps for the cell that contains the @InvTotal@ placeholder.

Note

Elements can have more than one class. Separate class names by a space.
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20. Open the Stylesheets dialog and click the Add button to create a new style-set.

21. As selector, type .invtotal (note the dot). This will make the new rules apply to any
element that has the class invtotal.

22. On the Type tab, in the Color field, typeWhite. This turns the text color into white.
23. Click the small square next to the Background Color field. The Color dialog appears.

Under RGB, enter:
R: 144, G: 144, B: 144.

24. Click OK to close the Color dialog. Now the table looks like this:

5. Editing a style sheet
As you’ve seen in the Stylesheets dialog, a rule consists of a selector and a set of style rules.

The selector points to the HTML element you want to style. The style-set contains one or more
declarations, each ending with a semicolon. A declaration includes a property name and a
value, separated by a colon.

In this exercise you will add padding to table cells and change the font size by editing a CSS
file directly, instead of via the Stylesheets dialog. As you gain more knowledge of CSS, this
option will become increasingly convenient.

1. On the Resources pane, expand the Stylesheets folder and double-click context_
print_styles.css. The file opens in the Workspace. You will see that it already contains
the selectors and style rules that were added via the Stylesheets dialog.

2. Add the following style rules to the style-set for #invoice-data td:
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font-size: 10pt;

padding: 6pt 2pt;

Padding is the margin inside an element, in this case, a table cell.
3. Press Ctrl + S to save the style sheet.

Note

Never edit a CSS file in the workspace and via the Stylesheets dialog at the same
time!

4. Click the My OLSG Invoice tab and toggle to Preview mode. Because of the padding and
the changed font size, you will need to resize the columns to make most product
descriptions fit on one line again. (Enable the Allow Resizing option first.)
The final table layout will look similar to the following image:
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Adding a variable address (using a
snippet, master page and script)
The only thing that’s still missing in the invoice is the address of the sender. The sender is a
company that has offices in different cities. All addresses are available in one snippet. In this
exercise you will learn how to write a script that inserts part of a snippet in the template,
depending on the value of a field in the record set.

1. Importing a snippet
Snippets are small HTML files. They are imported in much the same way as images are
imported.

1. Locate the snippet olsg_address.html, provided with this tutorial.
2. Drag the snippet to the Snippets folder in the Resources pane.
3. Click OK to confirm that the encoding is UTF-8.

4. Double-click the new snippet to open it in the Workspace.
5. Click the Source tab at the bottom of the Workspace to view the HTML of the snippet.

Every paragraph in this snippet has an ID that is identical to one of the values used in the
StateAbbrev field, as you can see in the Data Model pane. These IDs will eventually be
used to select a paragraph from the snippet and insert that in the template.

6. Close the snippet by closing the tab.

2. Inserting a Box on the Master Page
In this invoice, the letterhead is the same on every page and the address should appear on
every page as well. The best place for this type of elements is the Master Page. In this exercise
you will learn how to create a Box on a Master Page.

1. On the Resources pane, expand the Master pages folder.
2. Double-click Master page 1 to open it.
3. Click the Insert Positioned Box toolbar button.

Page 35



4. Drag and resize the Box to fit on the lowest part of the page, as in this image:

5. Give the Box an ID: on the Attributes pane, in the ID field, type olsg-address. This will
be used as the selector of the script. In the box, you could type a placeholder, for example
{address}, but that isn’t really necessary. In this case the script will simply replace all of
the contents of the box.

6. Save the Master Page (Ctrl S) and reopen the Invoice template (on the Resources pane,
expand Contexts, Print and then double-click the Invoice template).

Note

Although in this walkthrough we will only use one Master Page, it is common to have
more than one Master Page and apply different Master Pages to different pages in a
template. This is called Sheet Configuration. To open the Sheet Configuration dialog,
open the Resources pane, expand Contexts, then Print; right-click the Invoice template
and select Sheet Configuration.

3. Write a script that uses a snippet
In this exercise you will learn how to write a script that fills the box on the Master Page with a
variable address. The addresses are stored in a snippet.

1. Right-click the box and choose New Script from the shortcut menu. The Script editor
appears. The of the script is added automatically.
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2. Change the script name to Change Company Address.
3. Add the following script.

var office="";

if(record.fields.StateAbbrev == "ON"){

office = loadhtml("snippets/olsg_address.html", "#ON");

} else {

office = loadhtml("snippets/olsg_address.html", "#QC");

}

results.html(office);

In Preview mode and when output is generated, this script will read the value of the
StateAbbrev field in the current record. If it is "ON", for Ontario, it will load the paragraph
that contains the address of the office in Ontario from the snippet and insert that in the
template. All other recipients get the address of the office in Québec.

Tip

To match every state abbreviation to an address in the snippet, you could use a
switch statement; see the file Case_ChangeCompanyAddress.txt that is provided
with this tutorial.

4. Click OK and switch to Preview mode to see if the correct address appears in the
template.
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The finishing touch

1. Adding page numbers
Invoices consist of a variable number of pages, so they need to have page numbers. This
exercise shows how to add page numbers to a template.

1. Open the Master Page. The page number should appear on every page, so the best
place to put it in is the Master Page.

2. Add a Positioned Box and put it at the bottom right, next to the box for the company
address.

3. In the box, type Page (followed by a space).
4. From the menu, select Insert > Special Character > Markers > Page Number.
5. Type a space, then of, followed by a space.
6. From the menu, select Insert > Special Character > Markers > Page Count.

7. Click the Align Right icon on the toolbar to align this text to the right of the box.
8. Save the Master Page.
9. Reopen the Invoice template.
10. Toggle to Preview mode to see if the page numbers are inserted correctly.

Tip

To change the page number format to, for example, uppercase Roman numerals (I, II, III)
or lowercase letters (a, b, c), right-click the Invoice template on the Resources pane and
select Numbering.
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2. Using an image as a whitespace element
In this exercise you will add an image to the invoice to be used as a white space filler.

White space on an invoice can be very well used to include an advert or announcement. If there
is white space on some invoices, but not on others, you may insert an image in the template
and tag it as a whitespace element. A whitespace element will only be included in the output if
it fits in the available white space on the current page.

1. In Design mode, add one new paragraph below the paragraph Terms and Conditions:
place the cursor at the end of that paragraph and press Enter.

2. Import the image: locate the images folder provided with this tutorial, and drag olsg_
whitespace_hockey_01.pdf from that folder to the Images folder in the Resources
pane.

3. Place the image in the template: drag olsg_whitespace_hockey_01.pdf from the
Images folder to the empty paragraph. The image is inserted at the cursor position and
anchored to the text. This means that new lines added above the image will push the
image down.

4. Select the image in the document. When selected, images can be resized by dragging the
resize handles. Resize the image if needed. Keep the Shift key pressed while resizing to
scale the image proportionally.
Note that the Source field in the Attributes pane shows the path to the image e.g.
“images/olsg_whitespace_hockey_01.pdf”. In this path, "images" refers to the Images
folder in the Resources pane.

5. The breadcrumbs show that the selected image is inside a paragraph. Click the p in the
breadcrumbs to select the paragraph that contains the image.
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Note

Only top-level elements can be used as whitespace element. In the breadcrumbs,
top-level elements come first.

6. On the Attributes pane, check theWhitespace option.
7. Switch to Preview mode and browse the records to see that the invoice only shows the

image if it has space for it.

Note

If you want a larger distance between the text of the invoice and the whitespace filler
image, don’t add a paragraph; that could result in an extra page. Instead, set a top
margin for the image:

1. Right-click the image and choose Image…
2. On the Spacing tab, in Margins, uncheck All sides and enter a top margin (for

example, 10px).

3. Switching images dynamically
In this exercise you will learn how to write a script that replaces one image by another,
depending on values in the record set.

The Marketing department has provided four images:

l The hockey advert should only be presented to people who like hockey; men should get
the green version (olsg_whitespace_hockey_01.pdf) and women the purple version
(olsg_whitespace_hockey_02.pdf).

l Recipients whose favorite hobby is to ski should get the skiing advert; olsg_whitespace_
skis_01.pdf is for men, olsg_whitespace_skis_02.pdf for women.

1. Import the extra images: locate the images folder provided with this tutorial and drag the
images that are needed to the Images folder in the Resources pane.
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2. Click the image in the template to select it and give it an ID: on the Attributes pane, in the
ID field, type olsg-banner.

3. Right-click the image and choose New Script from the shortcut menu. The Script editor
appears. The selector of the script is added automatically.

4. Change the script name to Switch Banner.
5. Add the following script:

if (record.fields.FavHobby == "skate") {

if (record.fields.Gender == "M") {

results.attr("src", "images/olsg_whitespace_hockey_01.pdf");

} else {

results.attr("src", "images/olsg_whitespace_hockey_02.pdf");

}

} else {

if (record.fields.Gender == "M") {

results.attr("src", "images/olsg_whitespace_skis_01.pdf");

} else {

results.attr("src", "images/olsg_whitespace_skis_02.pdf");

}

}

Scripts start by performing a query: they scan the template to find all elements that match
the specified selector. This script will look for an element that has the ID olsg-banner.
Then, following the conditions, it attributes a different source to the results of that query –
which in this case is the image.

6. Click OK to close the dialog and toggle to Preview mode to see if the script works as
expected.

4. Switching Media dynamically
The Marketing department has also provided a new letterhead, to match the images that are
colored purple. In this exercise you will use that as a second Media and create a script to switch
the Media based on a data value.

1. Import the new letterhead: locate the images folder provided with this tutorial and drag
olsg-letterhead-letter-purple.PDF to the Images folder in the Resources pane.
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2. Right-click the Media folder in the Resources pane and select NewMedia. The Media
Properties dialog appears.

3. On the Virtual Stationery tab, check the Front option and click the Select Image icon.
4. Select olsg-letterhead-letter-purple.PDF from the list of resources and click OK.
5. Click OK to create the new Media entry.

6. Right-click the Media 1 entry and select Rename. Rename the Media to Media_green.
7. Rename the second Media entry to Media_purple.
8. Open the Sheet Configuration dialog: right-click the invoice and select Sheet

Configuration.
9. Click the Edit Script icon.
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10. The Edit Script dialog appears. Change the name of the script to Switch Media.

11. Replace the existing script with the following code. It contains a condition to toggle the
Media when the hobby of the recipient is skating:

if (record.fields.FavHobby == "skate") {

results.attr("content","Media_green");

} else {

results.attr("content","Media_purple");

}

12. Click OK to create the script entry. The entry is added to the Scripts pane.

13. Click OK to close the Sheet Configuration dialog.

14. Toggle to the Preview mode and browse through the records to see if the script works as
expected.

5. Keeping elements together
While browsing the records in Preview mode you may have noticed that sometimes the
heading "Terms and conditions" and the paragraph beneath it are on different pages. These
two elements should stick together. This can be arranged using the CSS page-break-after

property.

1. Choose Edit > Stylesheets… to make the Stylesheets dialog appear.

2. From the Context drop-down, choose Print.
3. Click the Plus icon to create a new style rule.

4. In the dialog that appears, type h3 in the Selector field. This means that the rule will
apply to all level 3 headings.

5. Click the Formats tab.
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6. In the Breaks section, from the After drop-down, choose avoid.
7. Reduce the space between the heading and the paragraph: on the Spacing tab, in

Margins, uncheck All sides and add a margin of 2px to the bottom of the heading.

8. Click OK to close the Rule editor.

9. Click Save to close the Stylesheet editor and go to Preview mode to check the effect of
the rules.

The invoice is now ready. The result should look similar to this:
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What’s next?
When a template is ready, it can be merged with a record set and outputted to a printer or to a
file. It can also be sent to the Workflow module, to be used in automated workflows, in
conjunction with a Data Mapping Configuration.

To get an introduction to the DataMapper module, please proceed with the XML Data Mapping
Configuration Walkthrough.

This tutorial has taught you to create a basic invoice from scratch. You now know common
techniques that are applicable to other document types too. For more techniques and useful
tips and tricks, please visit learn.objectiflune.com and help.objectiflune.com.
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