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Introduction 

Connect Workflow lets you automate the processing, distribution and printing of business 

documents. Once installed on a server, it can be set up to automate all tasks related to 

document processes. 

Workflow caters for inputs from a huge variety of sources, such as email, web pages, databases, 

individual files (PDF, CSV, XML, etc), print streams, FTP, and ERP systems. This data can then be 

analyzed, modified, stored, verified, routed and used as triggers for other processes entirely 

within Workflow. And of course it can be merged with Designer templates and outputted in 

multiple ways (printed, emailed, archived, sent to third party solutions, etc.). 

 

This walkthrough will teach you how to create a print process for Connect documents – invoices 

in this case - in the Workflow Configuration tool.  

It consists of three parts. The first part shows how to build the simplest possible print process. 

Each following part gives you more control over the process and its output and introduces a few 

more key aspects of Workflow. 

The final process merges data with a template to create invoices, prints them to different files – 

grouped by their number of pages - and archives each individual invoice in a folder. 

 

You will discover the required Connect tasks and the appropriate order of tasks in this process 

and you will learn how to create a branch in a process.  

You will also be introduced to basic Workflow concepts, such as the job file and metadata. This 

helps you understand what is going on in the process and will make it easier for you to build 

other Workflow processes in the future. 
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Part 1: A simple print process 

This part shows you the quickest and easiest way to build a print process in Connect Workflow. 
You will learn how to create a Workflow Print process that uses the All In One plugin.  

A print process in Workflow normally requires just two or three tasks. (The input file required by 
each of the plugins is underlined.) 

 An Input task, often a Folder Capture task. This task retrieves files corresponding to a 

specified file mask, from a specified folder. The input file typically contains data to be 

merged with a template. 

 The All In One plugin. This plugin combines four different OL Connect plugins:  

o The Execute Data Mapping task. This task generates a record set by executing a data 

mapping configuration on a given data file. 

o The Create Print Content task. This task creates a set of print content items by merging a 

template’s Print context with the records generated by the Execute Data Mapping task. 

o The Create Job task. This task creates a job set. It collects print content items generated 

by the Create Print Content task, and can filter and rearrange them using a Job Preset. 

The (optional) Job Preset needs to be created in Connect Designer. 

o The Create Output task. This task takes a job set and generates print output (a spool file, 

or files on disk) in a format specified by an Output Preset, and sends this output to the 

appropriate target location. The Output Preset needs to be created in Connect Designer. 

 A Send To Folder task (optional), to save the output to a file. 

 

Why use the All in One plugin? 

The All in One task is optimized: it exchanges less data with the server than the plugins do when 

used separately, and content creation can already start whilst the data mapping is in progress. 

One limitation of the All in One is that it can’t use a Job Preset to group, filter and sort print 

content items. When necessary, the All in One can be configured to carry out just the two first 

tasks, as will be demonstrated in part 2 of this walkthrough. Even then, the All in One delivers 

better performance than the individual plugins. 

Preparation: collecting the necessary files 

To be able to follow this walkthrough you’ll need the following Connect files: 

- A data file. The XML file provided with this tutorial: olsg-data.XML, contains the data to be 

merged with the template. 

- A data mapping configuration. Use the file OLSG-invoice.OL-Datamapper provided with this 

tutorial or the configuration that is the result of the DataMapper tutorial ‘Creating an XML 
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Data Mapping Configuration’. This data mapping configuration was designed to match the 

supplied XML file. 

- A template with a Print context. The template OLSG-invoice.OL-template is provided with 

this tutorial. Alternatively, you could use the template that is the result of the Designer 

tutorial ‘Creating an invoice’. 

 

This walkthrough starts with a simple print process without grouping, sorting or filtering, so no 

Job Preset is needed at this time.  

 

In addition to the data file, data mapping configuration and template, the All In One plugin does 

need an Output Preset. An Output Preset determines in what format and to which destination a 

print job is outputted. You will create one in the first exercise. 

1. Creating an Output Preset 

This exercise shows how to create an Output Preset to store print output in one PDF file. 

1. If it isn’t running already, launch Connect Designer by double-clicking the application 

icon. 

2. Choose File > Print Presets > Output Creation Settings… The Output Creation dialog 

appears. 

3. Make sure that <New> is selected as the configuration name. 

4. Click Next to go to the Print options page. 
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5. Select Generic PDF in the Printer model drop-down.  

Note: In a new installation, Generic PDF is the only listed option. If you have a printer at hand, 

you may click the Import Definition button at the right, select Edit available printers and add 

your printer model to the list. 

In this walkthrough it is assumed that the output has to be saved to a file. 

6. Select Prompt for file name. Of course, in an automated process you don’t want to be 

prompted for a file name, but don’t worry: you won’t. The print process in Workflow 

will be configured to determine the actual output location. Therefore you could choose 

any option for the output type here; however Prompt for file name is easiest because 

you don’t have to make any additional settings. 

Tip: Check Print virtual stationery if you want the template’s Media to be printed when 

generating the invoice in a PDF format. Media (also called virtual stationery) are PDF files 

representing preprinted paper. 

7. Click Next, then Finish. The Save file window is opened. 

8. Give the Output Preset a name, for example PDF-no-options, and click Save. The 

Output Preset is saved with the name PDF-no-options.OL-outputpreset. 

The Output Preset's default location is 

C:\Users\<username>\Connect\workspace\configurations\OutputCreationConfig. 

2. Sending Connect Designer documents to Workflow 

Before the required files can be used in Workflow, they have to be sent to Workflow from within 

the Designer. 

1. Choose File > Send to Workflow… The Send to Workflow/File dialog appears. 

2. Select the template: click on the Browse for template file button to the right of the 

Template field and select OLSG-invoice.OL-template (or the template that you have 

made following the Designer tutorial ‘Creating an Invoice’). 

3. Select the data mapping configuration: click on the icon to the right of the Data 

mapping configuration field and select OLSG-invoice_XML.OL-datamapper (or the data 
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mapping configuration that you have made, guided by the DataMapper tutorial 

‘Creating an XML Data Mapping Configuration’). 

4. Select the Output Preset PDF-no-options.OL-outputpreset from the Output Creation 

Preset drop-down list. 

5. In Destination, select your Workflow IP address and click OK. All selected files are now 

sent to Workflow. 

If no IP address is displayed, select Save to File… to create a package file. To import a 

package file in Connect Workflow, right-click Connect Resources in the Configuration 

Components pane and select Import Connect Content. 

6. Launch the Workflow Configuration tool and verify that all the necessary files are 

available by browsing the subfolders under Connect Resources, in the Configuration 

Components pane. 

Creating a print process 

3. Creating a Workflow configuration 

To start creating a new Workflow configuration, click the Workflow button (W) at the upper left 

hand corner and choose New. 
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A Workflow configuration can consist of many processes. One process is always added at the 

start of a new configuration. By default it has two tasks: a Folder Capture input task and a Send 

To Folder output task. 

The Folder Capture task is configured to pick up any file from the C:\source folder. The Send To 

Folder task outputs the input file, renamed but otherwise unchanged, to the C:\out folder. 

1. Save the configuration: click the Workflow button (W) and choose Save As. Type a name 

and click OK. 

4. Creating a process and renaming it 

The automatically added process is a good starting point for the print process so you don’t have 

to add a process. But if you’d want to, you can add a process by right-clicking on Processes in 

the Configuration Components pane and then selecting Insert > Insert Process, or by clicking 

Process on the Home ribbon. To delete a process, right-click on the process and select Delete. 

1. Rename the process by right-clicking on it and then selecting Rename. Enter Print 

process, for example. 
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5. Configuring the Folder Capture task 

There are different kinds of Input tasks, as you can see on the Inputs tab in the Plug-in Bar. (The 

Plug-in Bar is located to the right of the Process area). The Folder Capture task retrieves files 

corresponding to a specified file mask, from a specified folder. In this exercise you will learn how 

to configure the Folder Capture task. 

1. Double-click the Folder Capture task in the process area, or right-click on it and select 

Properties. The Folder Capture Properties dialog appears. 

2. Click the Browse button next to the Folder List, and select the folder that you want to be 

monitored. For this walkthrough it doesn’t matter which folder you choose, as long as 

you have access to it. 

3. Change the Masks to *.xml 

JOB FILE 

Every time a file is picked up, the process starts and the input file becomes the job file. This file 

will be handed down through the process, from one task to another. It may be changed, copied, 

and split by tasks in the process. Often, as in this case, the job file is a data file, but it could also 

be an image or another type of file. 

Each branch in a Workflow process can hold no more than one job file. If more than one file is 

retrieved via an Input task, then the entire process is run for each file sequentially. If the job file 

gets split during the process, then the rest of the process is run as a loop for each split portion. 

(In this walkthrough the job file is not split. It does get copied, in part 3).  

6. Adding the All In One plugin 

Now you can add and configure the All In One plugin. 
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1. Click on the OL Connect tab in the Plug-in Bar. This is where all OL Connect tasks are 

displayed. 

2. Locate the All in One task and drag and drop it after the input task. 

3. Choose Action to insert this task as an Action task.  

ACTION/OUTPUT TASK 

An Action task can be followed by other tasks, while an Output task is always located at the end 

of a process or branch. 

The All In One Properties window appears. 

4. On the Data Mapper tab, select the data mapping configuration OLSG-invoice_XML.OL-

datamapper (or your own data mapping configuration, if you’ve made one with the 

Datamapper tutorial). 

5. On the Content Creation tab, select the template OLSG-invoice.OL-template (or the 

template that you have made following the Designer tutorial ‘Creating an Invoice’). 
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Note: There is no Job Creation tab because the All In One plugin doesn’t use a Job Preset. It can 

only create a job without sorting, filtering or grouping the print content items. 

6. On the Output Creation tab select the Output Preset you have made in the first exercise: 

PDF-no-options.OL-outputpreset. 

7. On the same tab, in the Output Management section, check the Through Workflow 

option. This means that the output file will be handed down to the next task in the 

process (the Send To Folder task in this case). Every option set in the Output Preset is 

still used, except for the output location. 

8. Click OK. 

The process flow looks like this:  

Note: In this part of the walkthrough the Send To Folder task is maintained as a separate output 

plugin to be able to introduce you to a few key concepts in Workflow. But the simplest possible 

print process would consist of the Folder Capture and All In One task only. You could simply drag 

the All In One on the Send To Folder task to add it as an Output task. For this the Output Preset 

would have to define an actual directory or printer to send the output to. 

7. Configuring the Send To Folder task 

This exercise explains how to configure the Send To Folder task. The Send To Folder task saves 

the job file to a file. 

The last task in the All In One (the output creation task) replaces the original job file – the input 

data file - with the output PDF file. So, at this point in this particular process the job file is the 

output file. 

1. Double-click the Send To Folder task, or right-click it and select Properties. 

The Send To Folder Properties window appears. 
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2. On the General tab, click the Browse folder button next to the Folder field and select an 

output folder. Again, for this walkthrough it doesn’t matter which folder you choose, as 

long as you have access to it. 

3. The File name field reads %f. This is a system variable that represents the job file name.  

Right-click the File name field. A contextual menu appears, giving access to variables and 

data selection functions. 

Tip: Right-clicking on any a field with a maroon field name opens the contextual menu that gives 

access to variables and data selection functions. 

4. Select Variables > System > %O (Original file name without extension) and complete the 

file name by adding .PDF 

5. Click OK. 

Running the print process 

When the process is complete, you can test it in debug mode within the Workflow configuration 
tool, before sending it to the Connect Workflow service. First, though, you have to enter the 
appropriate server connection settings. 

8. Entering Connect Proxy information 

All OL Connect tasks require the OL Connect Proxy information. The tab OL Connect Proxy, 
present in the Properties window of each task, defines where to process the jobs sent through 
OL Connect tasks. This is common to all OL Connect tasks. The required information is:  
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 OL Connect Proxy Address: the machine name or IP Address where the OL Connect Server 

resides. If Connect Server is installed on the same machine as the Workflow Configuration 

tool, this is localhost. 

 Port: the port used to communicate with the OL Connect Server. Default: 9340. 

 Username: the user name expected by the OL Connect Server. By default it is ol-admin. 

Take a look in the Connect Server configuration or in the Connect Designer preferences to 

see which user name is used. (Open Connect Designer and choose Window > Preferences > 

Print > General.) 

 Password: the password expected by the OL Connect Server for the above user name. By 

default the password is set to secret. 

Usually these values are not set per task. You can set the default values in the OL Connect User 
options page of the Workflow Preferences: 

1. Click on the Workflow button (W) and then on the Preferences button on the bottom 

right. 

The Preferences dialog appears. 

2. Click OL Connect in the Behavior section on the left. 

3. Enter the appropriate information under Server Connection Settings. 

9. Debugging the process 

The process is now complete. You can test it within the Workflow configuration tool before 
sending it to the Connect Workflow service.  

Use the XML data source file (olsg-data.xml) example provided with this walkthrough to debug 
the process. 

1. Click Debug in the top menu to open the Debug ribbon. 
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2. Click Select. Browse to the XML file (olsg-data.xml), select it and click OK. 

Tip: You can also use a sample data file included in a data mapper configuration. Select Connect 

Resources > Data Mapping Configurations > your data mapping configuration, right-click a data 

file and choose Set as sample data file. 

The Run, Step, Skip and other buttons become enabled after a data file has been 

selected. You can now debug the process using these buttons. 

3. Click Run. This executes the entire process in one go. 

In the Process area, a blue arrow pointing downwards signals which task is currently 

being executed. 

The Messages pane gives information about each task and displays any error messages. 

The Debug Information pane gives information about the job and displays the contents 

of Workflow variables.  

4. Open the Windows File Explorer, browse to your output directory and check that the 

output file is there. When you double-click the output file it will be opened with the 

default PDF reader (often a browser). 

10.  Stepping through the process 

By executing the process one step at a time, you can observe changes in the data to understand 

exactly what is happening.  

1. Test the process again, now using Step. After each step: 

 Open the job file as Text (click View as Text, or double-click the name of the job file 

in the Debug Information pane). 

You will see that the job file is a copy of the XML input file – until the All In One 

plugin has completed its job. 

 Open the metadata file (click View Metadata, once the link is enabled, or double-

click the name of the Metadata file in the Debug Information pane).  

METADATA FILE  

When an OL Connect task adds data to the Connect database it also adds data about that data 

to the metadata file. Metadata aren’t created just to make debugging easier. These metadata 

tell the next step in the process what it needs to work on. They could also be used by other tasks 

to refer to the entities in the Connect database (not demonstrated in this walkthrough). A set of 

special Workflow plugins allows to edit the metadata during a Workflow process.  
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OL Connect tasks store their metadata under User defined information. 

 Open the job file as PDF (click View as PDF, once the link is enabled). The last task 

in the All In One (the output creation task) replaces the original job file – the XML 

file - with the output PDF file.  

2. Check the output in your output folder again. The previous file has been overwritten. 

11. Sending the configuration to the Connect Workflow service 

No errors, or all problems solved? Then the Workflow configuration can be ‘sent’ to the Connect 

Workflow service. 

Note: The Connect Workflow service can only run one configuration at the same time. The 

service reads its configuration file when it starts up. If the service is running when you send a 

new configuration, it automatically stops and restarts with the new configuration. 

1. Click on the Send configuration icon in the toolbar at the top left of the screen. 

 
 

Or use the menu: click the Workflow button (W) > Send Configuration > Send Local. 

2. Start (or restart) the services: on the Tools tab in the menu, click Services status > Start. 

12.  Testing the configuration on the server 

Finally, verify that the Connect Workflow service functions as expected with the new 

configuration file.  

1. Copy the XML data source file (olsg-data.xml) to the input folder defined in the Folder 

Capture task. 
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The file will almost immediately disappear from the folder when it is picked up by the 

Folder Capture input task. 

2. The print process is executed automatically. When it has finished, you can open the PDF 

output file in the folder that you have selected in the Send To Folder task. 
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Part 2: An advanced print process 

The process built in Part 1 of this walkthrough can only print a simple job without grouping, 
sorting, filtering or commingling. 
 
This part of the walkthrough shows how to create a print process that outputs groups of 
documents to different files (or jobs). 

Grouping and sorting documents and outputting them to different print jobs can be important, 
not just for large mailers who earn a discount by pre-sorting their mail, but also for smaller 
companies, for example when some documents have to be put in bigger envelopes than other 
documents. 
 
Key elements in an advanced print process are the Job Preset and Output Preset. A Job Preset 
can group, filter and sort the print content items that have been generated when merging a 
template with a record set. An Output Preset can then split the output in different files or jobs. 

Creating the Print Presets 

In this exercise you will create both the Job Preset and Output Preset for a print process that 

groups invoices by their number of pages and outputs each group of invoices to a different file. 

1. Job Preset: grouping 

This Job Preset groups items by their number of pages (1 to 2, or above), so that the actual 

output can be split into one file (or one job if the output task would actually output to a printer 

or printer queue) containing documents that have one or two pages, and one with larger 

documents. 

1. Launch Connect Designer by double-clicking the application icon. 

2. Choose File > Print Presets > Job Creation Settings… The Job Creation dialog appears. 

3. Click on the Browse button to the right of the Data Mapping Config drop-down list and 

select the data mapping configuration for XML provided with this tutorial: OLSG-

invoice.OL-Datamapper, or the data mapping configuration that you’ve created with 

the DataMapper tutorial ‘Creating an XML Data Mapping Configuration’. 
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Without a data mapping configuration it isn’t possible to select a data field in the criteria 

for grouping. 

4. Check Use grouping in the Options section and click Next. The Grouping Options dialog 

opens with the Job Grouping Fields tab selected by default. 

The tabs are supplementary to one another, so you could group documents in 

document sets, job segments and jobs. The lower part of this dialog is reserved for page 

break grouping options. 

5. In this exercise we’re only grouping the documents by their number of pages. Check 

Page Break Grouping. 

Note: Page break grouping can also be used in addition to ‘normal’ grouping. It can take place 

before or after the grouping on the chosen level. 

6. Page break grouping can only be done on one level. Select Job Segment from the 

Grouping Level drop-down list. 

7. Click the Add button to add a page range. 

8. Change Page Range 1 so that it contains all documents from 1 to 2 pages: click in the To 

field and type 2. Page range 2 is automatically adjusted to contain all documents larger 

than two pages. 

9. Click Finish. The Save file window opens. 

10. In the Name field type the name for your job file configuration: Group-by-pages, and 

click Save. Your job file configuration is saved with the name Group-by-pages.OL-

jobpreset. A Job Preset's default location is 

C:\Users\<username>\Connect\workspace\configurations\JobCreationConfig. 
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2. Output Preset: separation 

This Output Preset splits the groups of content items and outputs them to different jobs/files.  

1. In the Connect Designer, choose File > Print Presets > Output Creation Settings… The 

Output Creation dialog appears. 

2. Select <New> as configuration name. Click Next. 

3. Select Generic PDF in the Printer model drop-down. 

4. Select Directory and enter a directory. 

5. In the Output Mask field, type Group_${file.nr}.pdf. 

Tip: For a list of variables that start with $ see: http://help.objectiflune.com/en/planetpress-

connect-user-guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm 

You will learn how to use variable data in file names in the next part of this 

walkthrough. 

6. Check Separation, then click Next. 

7. The invoices have been grouped on the Job Segment level in the Job Creation task. 

Choose Job Segment from the Separation drop-down list under Separation Options to 

create one file for each of these groups. 

http://help.objectiflune.com/en/planetpress-connect-user-guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm
http://help.objectiflune.com/en/planetpress-connect-user-guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm
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8. Click Next, then Finish. The Save file window is opened. 

9. Type a name for the Output Preset, for example PDF-separate-jobsegments, in the 

Name field and click Save.  The Output Preset is saved in the Connect workspace folder 

with the name PDF-separate-jobsegments.OL-outputpreset. 

10. Send the Job Preset and Output Preset to Workflow (File > Send to Workflow…). The 

new presets are listed in the drop-down lists in the Send to Workflow/file dialog. 

Adjusting the print process 

Launch the Workflow Configuration tool if it isn’t running yet. The files sent from the Designer 

will automatically be unpacked and can be found in the Connect Resources folder. Now the print 

process has to be adjusted to use these files. 

The All In One plugin, used in the simple print process made in Part 1, can’t use a Job Preset. It 

always delivers the output as an unsorted, ungrouped job or file. 

To enable a print process to do grouping, filtering or sorting, Create Output has to be turned off 

in the All In One plugin, and the Job Creation and Output Creation tasks must be added to the 

print process. 

Note: It is also possible to remove the All In One and replace it by all four plugins that make up a 

print process (Execute Data Mapping, Create Print Content, Create Job and Create Output). 

However that should only be done when it is absolutely necessary (e.g. when the extracted data 

have to be edited or enhanced before the print content is created). In any other case, turning 

Create Output off is the best solution.  

3. Turning off Output Creation in the All in One task 

First you will learn how to turn off Output Creation in the All in One plugin. 

1. Double-click the All In One plugin. 

2. On the Output Creation tab, select None. The All In One plugin will now stop after 

having created the print content items. 
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4. Adding the Create Job task 

The next step is to add the Create Job plugin to the process. This plugin creates a job: a 

collection of content items. The items have to be grouped according to the Job Preset you have 

just made. 

1. In the Plug-in Bar, on the OL Connect tab, locate the Create Job task and drag and drop 

it underneath the All In One task.   

The Create Job Properties window opens. 

2. On the General tab, select the Job Preset Group-by-pages.OL-jobpreset. 

Note: Even with this plugin, using a Job Preset is not obligatory. The Default setting uses the IDs 

defined in the metadata to collect the print content items and put them in one job. 

3. Click OK.  

5. Adding the Create Output task 

The Create Output task generates and distributes print output in a format and to a destination 

(a printer queue, Windows printer, folder...) specified by an Output Preset. 

1. Locate the Create Output task on the OL Connect tab in the Plug-In Bar and drag and 

drop it on the Send To Folder task to replace it.  
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2. The Create Output Properties window appears. On the General tab, select the Output 

Preset: PDF-separate-jobsegments.OL-outputpreset. 

3. Click OK. The Print process now looks like this: 

6. Debugging the process 

1. Debug the process using the Step button on the Debug tab. Open the job file and 

metadata file after each step.  

The metadata file now displays data at different levels. Click on a Metadata level to the 

left, to see the data that has been attached on that level (under User defined 

information). The Job node has information about the job as a whole, a Group has 

information about a record set and a Document about one record. 

The Group node in this picture contains the ID of the content set in the Connect 

database: 
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Note: When working with OL Connect tasks, only Job, Group and Document nodes can contain 

information about the actual job. Although visible in the metadata file, the Datapage and Page 

nodes don't contain any actual job related information. 

In this process, viewing the output PDF isn’t possible, for two reasons: 

o The Create Output task is the last task in the process, so the output isn’t handed 

back to the process. 

o The Create Output task only replaces the job file with the PDF output if there is only 

one output file. When the output is separated it replaces the job file with a CSV file 

that lists the paths to the outputted files. 

2. Open the Explorer, browse to your output directory and check that the output files are 

there. You should get two output files: one for each page range. You can open them 

with a PDF reader or browser. 

3. Finally, upload the configuration to the Connect Workflow service and test it. 

7. Exercises (optional) 

A. Create a Job Preset that groups the documents by state instead of their number of pages. 

You should generate 10 output files, one for each state. 

 

Solution: 

1. Create a new Job Preset and open the same data mapping configuration as before. 

2. On the Job Segment tab, select the data field State in the Available Fields list. 

3. Click the blue arrow to add the selected data field to the Selected Fields area. 

4. Save the Job Preset with the name Group-by-state. 

5. Send the Job Preset to Workflow, select it in the Create Job plugin properties and try 

debugging the process.  

 

B. Try combining page break grouping with normal grouping. For example: 
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1. Open the Group-by-state Job Preset in the Designer: select File > Print Presets > Job 

Creation Settings… and choose Group-by-state from the Configuration Name drop-

down list. 

2. Add page break grouping on the Job Segment level and create two page ranges, one for 

documents with 1 – 2 pages and one for larger documents, just as in the Group-by-

pages Job Preset. Leave the other options unchecked. 

3. Save the Job Preset and send it to Workflow. Select this Job Preset in the Create Job 

plugin properties. Now try debugging the process. You should get one or two output 

files per state (one if there aren’t any documents larger than two pages for that state). 

Note that all documents with smaller invoices are generated first, and then all 

documents with larger invoices. 

4. Open the same Job Preset in the Designer and check the option Generate page break 

range groups after normal grouping.  

Note: The option Generate page break range groups after normal grouping only takes effect 

when normal grouping and page break grouping are applied at the same level. 

5. Save the Preset and send it to Workflow. Again, you should get one or two output files 

per state, but with this Job Preset they are generated in a different order: per state, 

instead of per page range. 

6. Open the same Job Preset in the Designer and remove the normal grouping on the Job 

Segment level. Instead, group documents by State on the Document Set level. 

7. Save the Preset and send it to Workflow. When you run this configuration, you should 

get two output files, one with the smaller documents, grouped by state, and one with 

the larger documents, also grouped by state. 
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Part 3 Adding a branch for archiving 

A process that archives invoices would up to a certain point do exactly the same as the process 

that prints the invoices. So instead of creating a whole new process, you can create a branch in 

the print process. Both the branch and the main process can use the Print Content items created 

by the All In One. The branch only needs a different Job Preset and Output Preset. 

1. Creating the Job Preset 

This Job Preset doesn’t group the documents, but provides the invoice number for each invoice, 

so that the invoices can be saved using their invoice number in the file name. 

1. Launch the Designer. 

2. Choose File > Print Presets > Job Creation Settings… 

3. Select the same data mapping configuration as before. 

4. The Configuration name should be set to <New>. 

5. Check Include meta data. 

6. Click Next. The Meta data options appear. 

Each tab in this dialog represents one of the five levels in a (PDF or AFP) output file: job, 

job segment, document set, document and page. A Job Preset can provide the Output 

Preset with tags on each of these levels. 

Note: These meta data tags can only be used in an Output Preset. They do not appear in the 

metadata file in Workflow. 

7. On the Document Tags tab, click the Add meta data button and select Add field meta 

data. 
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8. Choose InvNumber from the list of data fields and click OK. 

9. Click Finish.  

10. In the Save File window, type the name for your Job Preset, e.g. DocTags-InvNumber, 

and click Save. 

2. Creating the Output Preset 

The Output Preset that archives the invoices must be configured to store each invoice in a 

folder, using the invoice number in the file name, and to create one file for each document using 

the meta data tag provided by the Job Preset in the file name. 

 

This Output Preset splits the groups of content items and outputs them to different jobs/files.  

1. Choose File > Print Presets > Output Creation Settings… 

2. In the Output Creation dialog, select <New> as configuration name. Click Next. 

3. Select Generic PDF in the Printer model drop-down. 

4. Select Directory and enter a directory. 

5. Click the Options button next to the Output Mask field. 

6. Set File Separation to Document to make the process create one file per document. 

7. In the Output Mask field, enter ${document.metadata.InvNumber}.pdf. 

The part between brackets is a reference to the tag name defined on the Document tags 

tab in the Job Preset. (See: http://help.objectiflune.com/en/planetpress-connect-user-

guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm.) 

The specified tag points to a data field. Each time the Output Preset creates a file, it will 

look in the Connect database and use the value of that data field as the file name. 

http://help.objectiflune.com/en/planetpress-connect-user-guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm
http://help.objectiflune.com/en/planetpress-connect-user-guide/1.7/#designer/Output/Print/Variables_available_in_the_Output.htm
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8. Click OK. Note that the Separation option is now checked. 

9. Check Print Virtual Stationery to make the invoices look exactly like invoices printed on 

paper. 

10. Click Next and verify that the separation level is set to Document.  

11. Click Finish. Type a name for the Output Preset, for example PDF-archive, in the Name 

field and click Save.  The Output Preset is saved in the Connect workspace folder with 

the name PDF-archive.OL-outputpreset. 

12. Send the Job Preset and Output Preset to Workflow (File > Send to Workflow…), 

selecting the new presets from the drop-down lists in the Send to Workflow/file dialog. 

3. Adjusting the process: creating the branch 

This exercise shows how to create a branch in the advanced print process that archives the 

invoices. 

1. Launch Workflow and open the advanced print process. 

2. In the Plug-in Bar, the Process logic tab, locate the Branch task and drag and drop it 

underneath the All In One task.  

Note: Dragging an output plugin - such as the Create Output task - between two tasks in a 

process and adding it as an Output task creates a new branch with the respective plugin at its 

end. 

3. In the Plug-in Bar, in the OL Connect tab, locate the Create Job task and drag and drop it 

on the new branch. The Create Job Properties window opens. 

4. Set the Create Job task to use the DocTags-InvNumber Job Preset. 
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5. In the Plug-in Bar, in the OL Connect tab, locate the Create Output task and drag and 

drop it on the ‘Unknown’ output task.  

6. Set the Create Output task to use the PDF-archive Output Preset. 

The final process looks like this:  

4. Debugging the process 

Before sending the configuration to the Connect Workflow service, debug the process using the 
Step button. 

 Pay attention to the name of the job file and metadata file: they change once the process 

has entered the branch. The job file and metadata file get copied when the process enters a 
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branch. When the main process resumes after the branch has completed, it does so with the 

original files. 

 Note that branches are not executed simultaneously. When a process branches, steps in the 

branch are executed first. 

The process should now output one PDF per invoice in addition to the PDF files that contain the 
grouped invoices. 

5. Exercises (optional) 

A. Change the main process so that it outputs files named after their page range. 

 

Hints: 

 In the Grouping options, give each page range a name.  

 Use the Page break range meta data field name in the output file mask: 

${segment.metadata.PageBreakRange}.pdf 

B. Change the main process so that it groups invoices by state and creates output files named 

after the respective state (Alberta.pdf, etc). 

 

Hints: 

 Create a Group-by-state Job Preset; see Part 2, exercise 7A. 

 Add the State field as a Job Segment Tag to the Group-by-state Job Preset.  

 For the Output Preset, open the PDF-separate-jobsegments.OL-outputpreset and 

change the output file mask to ${segment.metadata.State}. 


