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Introduction
This tutorial introduces you to some of the basic functionality of Connect Designer. You will learn how 
to set up a personalized business letter by creating a new print document, add content from MS Word, 
import image resources, load a CSV data file and set up variable content elements.

Connect Designer lets you create and design print documents and emails in one place, and also web 
pages if you have PlanetPress or PReS Connect. Every aspect of your document can be easily per-
sonalized thanks to its feature-rich and user-friendly interface.

The file format of the documents utilizes HTML, the main markup language for displaying web pages 
and e-mail messages. Connect Designer extends this with paginated documents intended for print. 
When exploring the user interface you will see several items that reveal this underlying technology. 
Knowing HTML is not a requirement to work with the application: the user interface includes the appro-
priate features for both novice and advanced users.

This tutorial introduces you to some of the basic functionality of Connect Designer. You will learn how 
to set up a personalized business letter by creating a new print document. You will add content from MS 
Word, import image resources, load a CSV data file and set up variable content elements.

After having completed this walkthrough, you’ll have a basic knowledge of how to use Connect 
Designer, but there are more ways to do things and more things you can do. So, go on and explore! To 
discover new ways and enhance your skills, please visit https://olresourcecenter.uplandsoftware.com 
and the Help (PReS Connect or PlanetPress Connect).

Note: The resources needed for this walkthrough can be downloaded: Designer-Letter-
resources_2022.zip
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Creating a letter
This lesson introduces the concepts of sections, content and formatting. You will also learn how to nav-
igate the content.

1. Creating a print template
Start by creating a new document for print.

 1. Launch the Designer by double-clicking the application icon.

 2. In the Welcome screen, click Create a New Template and choose Word-based Print. Or 
choose File > New > Template > Word-based Print Template and click Next.  The New Word-
based Print Template dialog is shown to select .

The dialog lets you enter parameters for the new document, which includes its page size, the 
page margins and the number of sections. A section contains one or more pages. Text will flow 
automatically from one page to the next.

 3. Click Browse icon next the path: field to select a Word document. The file explorer opens. Select 
the sample file letter-text.docx from your local drive. 

Note: The Word document letter-text.docx is included in the resources that you have 
already saved to your local drive.

 4. Click Next. The initial page size, margins, and orientation are taken from the original document 
settings and displayed in the dialog window that appears. You can adjust them on that dialog win-
dow. 

 5. Make the following settings:    

 l Margin Top: 1.5in

 l Margin Right, Bottom and Left: 0.75in

The values may be converted into another measurement unit, depending on your settings (Win-
dow > Preferences > Print > Measurements).

Note: After the template is created, you can change the size of images and text boxes, and 
adjust the page size and margins.

 6. Click Finish. 
The new document is shown in the workspace. A Print context is created with the specified num-
ber of sections in it. For each page in the document, one page is created in the Print section. A 
separate word.css file is created in the Stylesheets. The css file is linked to the active section.

 7. To save the template, click File > Save As. The Save Template dialog box displays.
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 8. Navigate to a folder (preferably, the folder where you unzipped the sample files),  enter My OL 
Mobile letter.OL-template in the File name field and then click Save.

2. Formatting text
Connect Designer has many text editing and formatting capabilities. Applying formatting to selected 
text is referred to as local or inline formatting. Formatting could also be handled via style sheets, as 
will be demonstrated later.

 1. Select the text of the subject line: “Take advantage of our Bundle Offers”.

 2. Common text properties (e.g. font, size, color) can be set via the options in the Formatting tool-
bar. 
Click the B icon on the toolbar to bold the text.

 3. Another option is to format selected text using the Text formatting dialog. To open it, click 
Format > Text…. 

The dialog can also be invoked by pressing Ctrl + T or via the shortcut menu: right-click the selec-
ted text and choose Text...

 4. Change the font size to: 16pt.

 5. Click the Edit Color icon (the small square next to the color field). The Color Picker dialog 
appears. Colors can be specified in CMYK, RGB and HEX color values. 

 6. Choose the following color values:             

 l Cyan: 0, Magenta: 92, Yellow: 77, Black: 22

 l Color mode: CMYK (this will store the specified color using the CMYK values)

 7. Click OK twice, to close the dialogs.

Note: The style changes are applied to the selected text. When you press Enter somewhere in 
this text, a new paragraph is created that inherits these text styles.
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4. Exploring the document
This exercise shows how to explore the document and select elements on the page. 

 1. Take a look at the Outline pane. The Outline pane can be reached in the upper left area next to 
the main editor. In case the Outline pane isn’t available, choose Window > Show View > Out-
line.
The Outline pane shows a hierarchical tree structure of the pages and their elements and is use-
ful to quickly select elements. It represents the HTML Document Object Model or DOM - a term 
advanced HTML users will recognize.
In this example the Outline pane shows a series of paragraphs and two subheadings. The para-
graphs are presented by the <> p entries in the tree and the subheadings are marked with <> h2. 
Other common HTML elements are: h1 through h6 (headings), img (image), table, tr (table rows), 
td (table data or table cells), b (bold), span (a piece of styled text).

 2. Click a  paragraph element in the outline. The main document window highlights that paragraph 
and shows a thin line around its contents. The paragraph is now selected.

Note that the same information is shown below the title of the document. This line is referred to as 
the breadcrumbs.

 3. Use the arrow up and arrow down buttons to navigate through the elements in the outline.

 4. Place the cursor in the text “500 MB bandwidth”. Now the breadcrumbs read p > b. This signifies 
that the bold text is a child element of the paragraph.

 5. Click the b in the breadcrumbs to select the bold text.

 6. Click the p in the breadcrumbs to select the paragraph. Note that the element gets selected in the 
Outline pane too.    
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Adding personalization
To create a personalized document, you need information about the recipients: the first name, last 
name, email address, job title, etc. The exercises in this chapter show how to import a sample CSV 
data file and they demonstrate various techniques to add data fields to the page and to create dynamic 
content.

1. Loading a data file
A Comma Separated Values file (.csv) is a simple text format in which data are separated by commas 
or semicolons. When you load a CSV file, a wizard guides you through the process of importing the 
data and lets you set several import options.

 1. Choose File > Add Data > From File Data Source.... The Open Data Sample File dialog 
appears.

 2. Select the sample letter-data.csv file and click Open. The wizard for loading CSV files is now 
shown.

 3. Click Next to navigate to the second page of the wizard. Make the following settings:

 l Separator: Semicolon

 l Check the First row contains field names option.

 4. Click Finish. The extracted data is shown in the Data Model pane at the right. If this pane isn’t 
visible, choose Window > Show View > Data Model.

 5. Use the browse buttons in the Value column to browse through the imported data.

Note: PlanetPress and PReS Connect have more advanced options for importing data via the 
DataMapper. This module allows to extract, manipulate and use data from a wide range of data 
sources, including line printer data and PDF documents. It is not available in PrintShopMail Con-
nect.
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2. Adding a data field to the document
As soon as data have been imported, you are ready to start personalizing the document by adding data 
fields to the template. When you add a data field to the template, an expression is inserted at the cursor 
position. Expressions look like this: {{fieldname}}.  When the document is viewed in Preview mode (or 
when output is generated), the expression gets replaced with the value of the data field.

 1. Remove the text “customer” in the salutation of the letter.

 2. Select the first_name field in the Data Model view and drag the field after the text “Dear” in the 
document. On releasing the mouse button, the expression {{first_name}} is inserted at the 
cursor position.

 3. Switch the view mode of the document from Design to Preview by clicking the Preview tab at 
the bottom of the workspace. This shows the merge result. Use the browse controls in the Data 
Model pane to scan through the records. 

The expression {{first_name}} gets replaced with the value of the first_name data field in the current 
record. This is done by the Handlebars library which is integrated in OL Connect. For more inform-
ation see the online help: Handlebars in OL Connect.

In previous versions, variable data used to be inserted in a template via scripts and placeholders (see 
the online help: Variable data in text: scripts and placeholders). 
The advantage of expressions is that fewer scripts and sometimes no scripts at all are needed in a tem-
plate.

3. Adding multiple data fields in a single action
Now you will learn how to add multiple data fields to the document in a single action. We will add the 
name and job title of the sales representative who is the sender of this letter, to the end of the body.

 1. Toggle to the Design view of the document.

 2. Place the cursor after the text “Best Regards” and insert a few new paragraphs.

 3. Select the rep_first, rep_last and rep_title field in the Data Model pane by clicking each field 
while pressing the Ctrl key.

 4. Drag the selected fields to the end of the document.
An expression for each of the fields is added at the cursor position. The expressions are placed 
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on a single line.  The document shows the following expressions: {{rep_first}}{{rep_last}}{{rep_
title}}.

 5. Type a space between {{rep_first}} and {{rep_last}}.

 6. Place your cursor between {{rep_last}} and {{rep_title}} and press Shift + Enter to put the job 
title on a new line. 
A line break is added to the text. (In HTML this is the <br> element, as you can see in the Source 
view of the document.)

 7. The expressions can be formatted via the Format menu and the icons on the toolbar. Select the 
expressions {{rep_first}} and {{rep_last}} and click the Bold icon on the formatting toolbar.

 8. Toggle to the Preview mode and note that the value that replaces the expression is formatted 
just like the expression.

4. Creating an address block
In this step you will learn how to add variable data, not by dragging data fields to the document but by 
using the Handlebars Text Helper wizard instead. 
One of the big advantages of using a Handlebars Text Helper wizard is that it facilitates skipping empty 
lines when data fields are empty.

The Handlebars Text Helper wizard creates a Helper that concatenates multiple data fields and that 
can add a prefix and/or suffix to each data field. 

Note: A Helper is a function that can be used in an expression.

 1. Open the Handlebars Text Helper wizard: on the Scripts pane at the bottom left, click the black 
triangle on the New button and click Handlebars Text Helper. The Edit Text Helper dialog 
appears

 2. Change the name of the Helper so that it clearly describes the purpose of the script (e.g. setAd-
dress). The name must be unique.

 3. The Handlebars Text Helper wizard allows to select the data fields that need to be combined. 
Each field is placed on its own line in the wizard. New lines can be added by clicking the Plus sign 
next to the table or simply by clicking on the next empty line.
The Prefix and Suffix fields add text to the data of each field.
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Note: When a data field is empty the respective line is skipped including its prefix and suf-
fix.

Add lines for the following fields and set the respective suffix text.

Prefix Field Suffix
 company_name <br> (adds a line break)

 first_name one space

 last_name  

<br> address  

<br> city , (comma, then space)

 province &nbsp;&nbsp; (two non-breaking spaces)

 postal  

Note: The reason for using two non-breaking space characters (represented by the HTML 
entity “&nbsp;”) instead of two regular spaces, is that in HTML by default multiple standard 
spaces will be collapsed to a single space character.

 4. Under Options, verify that HTML is selected as Insert Method.

 5. Click OK. The name of the Helper, setAddress, is added to the Scripts pane under the Control 
scripts folder

 6. In the template, remove the text "@address@" at the start of the letter body. 

 7. In Design mode, drag and drop the setAddress Helper from the Scripts pane to the cursor pos-
ition. Alternatively, you can write the name of the Helper, enclosed in double curly braces: 
{{setAddress}}.
This creates an address block that will look like this:

company_name
first_name last_name
address
city province  postal

 8. Toggle to the Preview mode and use the browse buttons of the Data Model pane to navigate 
through the records.
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Position the address block
Some records do not contain a company_name value. For those records, the company_name line, 
including the <br> line return, will be absent. The city province postal line goes up or down one pos-
ition. 
This can be handy, but in this case the entire content of the letter moves up and down with the address.

There are several ways to overcome this problem. One is to insert an absolute positioned box via the 
toolbar and enter the {{setAddress}} expression in that box.  When using an absolute positioned box, 
the address block will no longer affect the position of the body, as it hovers above the main flow. 
Another solution is to wrap the expression with an inline box and set the height of that box.

To wrap the address in an absolute positioned box:

 1. In the Design mode, place the cursor in the expression {{setAddress}}. The breadcrumbs read p.

 2. Choose Insert > Wrap in Box. The Wrap in Box  dialog appears. 

Note: The Wrap in Box dialog allows to assign an ID or a class to the box. 
Scripts that use an ID or class as selector generally run faster than text scripts. 

 3. Click OK. The paragraph containing the expression {{setAddress}} is now wrapped in a box (an 
HTML <div> element) with resize handles.

 4. Change the height of the box so that it is big enough to contain the address. Push the subject line 
down.

 5. Toggle to the Preview mode and browse through the records.

5. Adding a dynamic date
In Connect Designer you can quickly insert a date. When you are preparing a template today and finish 
it tomorrow, the date can be updated automatically, so you don’t have to manually delete earlier dates.

To replace the “@date@” placeholder with a date:

 1. Toggle to the Design mode and select the “@date@” placeholder at the beginning of the tem-
plate.
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 2. Choose Insert > Date.... The Insert Date dialog appears.

 3. Select a language to define the notation of the date.

 4. Select the Update Automatically checkbox and choose the format of your preference.

 5. Click OK. A date script is added to the Scripts pane. This script returns today's date.

 6. Toggle to the Preview mode to see the script in action.

6. Creating a conditional paragraph
In this exercise you will learn how to create conditional content using the Make Conditional script wiz-
ard. This wizard provides a user interface to define when a certain element (or elements) should be hid-
den or shown. In this case we will show a paragraph for recipients living in the city of Montréal and hide 
it for others.

 1. Toggle to the Design mode and place the cursor  in the paragraph that starts with the text: “If you 
have friends living close by”. The paragraph is now selected.

 2. On the Attributes pane, type promo in the ID field.

 3. Right-click this paragraph and select Make Conditional in the shortcut menu. The Edit Script 
script wizard appears.
Note that the ID of the paragraph has become the selector of the script. The # sign is used to 
refer to an ID. A dot (for example: .promo) refers to a class.
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 4. Make the following settings:

 l Data field: city

 l Operator: Equal to

 l Value: Montreal

 5. Enter a meaningful name for the script and click OK to save the script.

 6. Toggle to Preview mode and browse through the records. The paragraph is shown for residents 
of Montreal and is hidden for others. Note that the text below this paragraph moves up when the 
content is not shown.

Tip: The same technique can be used to show and hide images.
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Working with images
Typically documents do not solely contain text. Often resources like logos and background images are 
added to complete the document. In this section you will learn how to work with images.

1. Importing and inserting images in the template
In this exercise you will learn how to import images and place them in your document. Images can be 
static elements or they can be dynamically replaced by scripts based on a data field.

 1. Take a look at the Resources pane at the top left. In case the Resources pane is not shown, 
choose Window > Show View > Resources.
The Resources pane shows files and other resources belonging to the active document. Files 
added to the Resources pane travel with the document when it is copied, sent via email or pub-
lished to the OL Connect PlanetPress/PReS Workflow component. The Resources pane is not 
limited to image resources; a document may require custom fonts, style sheets (CSS files), snip-
pets, etc.

 2. Locate the Images folder provided with this tutorial and copy promo_banner.pdf to the Images 
folder in the Resources pane.

 3. Enter an empty paragraph below the paragraph ending with “OL Mobile now offers you a 3-in-1 
bundle.”

 4. Drag promo_banner.pdf from the Images folder to the new line. The image is inserted at the 
cursor position and anchored to the text. Adding new lines above the image will push the image 
down.

 5. Select the image in the document and note that the Source field in the Attributes pane shows 
the path to the image: “images/promo_banner.pdf”. In this path, images refers to the Images 
folder in the Resources pane.
When selected, images can be resized by dragging the resize handles.             

Tip: Keep the Shift key pressed while resizing to proportionally scale the image.
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2. Adding a dynamic image
In this exercise you’ll learn how to create a variable signature by using the Dynamic Image script wiz-
ard. The Dynamic Image wizard provides a user interface to compose the path to image files using val-
ues from a data field.  (The same could be achieved using plain script, but this requires knowledge of 
JavaScript.)

 1. Import the images: locate the images folder provided with this tutorial and drag the signatures 
folder to the Images folder in the Resources pane. 
The signatures folder contains three signature images: Probst.jpg, van Houtten.jpg, and van 
Buel.jpg. The value of the data field rep_last is equal to the name of one of these images.

 2. Make sure there is an empty paragraph between “Best regards,” and the name of the sales rep-
resentative.

 3. Drag the Probst.jpg file from the Signatures folder in the Images folder on the Resources pane 
to the empty paragraph. The image is placed inline and will flow with the text when paragraphs 
are added or removed (like with the conditional paragraph).

 4. Click the image to select it. Its resize handles become active. Make the image a bit smaller (e.g. 
75% of its original size).

 5. Right-click the image to show the shortcut menu. Choose Dynamic Image.... The Dynamic 
Image wizard appears.

This wizard provides a simple way to replace images based on the value of a data field. In this 
case we are going to use the value of the rep_last data field to concatenate the path to the sig-
nature images. The three signature files already have the appropriate name.

On invoking the Dynamic Image wizard the path to the current image file is placed in the Prefix 
field and the file extension is added to the Suffix field.
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 6. Select rep_last in the drop down of the Field column. On previewing and outputting the doc-
ument the data is concatenated with the prefix and suffix data, which results in the path to the 
respective signature files.

 7. Enter a meaningful name for the script and click OK to save the changes.

 8. Toggle to Preview mode and browse through the records. Note that the signature image is 
replaced and matches the respective account manager.

Note: In the exercise above, we used the Dynamic Image wizard to create a dynamic image 
based on a data field. A Dynamic Image script writes the path of the image to the src attribute of 
the respective image.

Position the image

To reduce the distance between the image and the name of the sales representative, set the margins 
Bottom and left to 5px and -5px, respectively.

If you have used the Dynamic Image wizard, an image is already inserted in the template. In this case, 
you can change the margins as follows:
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 1. Right-click the image and select Image… from the shortcut menu. The Image properties dialog 
appears.

 2. Click the Spacing tab.

 3. Uncheck All sides in the Margin section.

 4. Enter -5mm in the Bottom field. This reduces the whitespace below the bounding box of the 
image.

 5. Enter -5mm in the Left margin field to make the image ‘hang’ outside the text flow.

3. Adding a Virtual Stationery background
In this exercise you will learn how to set a PDF image as a background to emulate pre-printed paper. By 
specifying a so called virtual stationery image you will be able to preview the pre-printed media and pos-
ition the content in the correct position. The image will be repeated for all pages that use this media.

To set a PDF as media:

 1. First import the PDF: locate the file letterhead.pdf that is provided with this tutorial and drag it to 
the Images folder on the Resources pane.

 2. Drag letterhead.pdf to the Media 1 entry in the Media folder on the Resources pane. The first 
page in the PDF will be set as the image for the front side of the media.

After adding the image to the media you will see that the image appears in the background of the page
(s). 

Page 20



Alternatively you could open the Media properties dialog by right-clicking the Media 1 entry and select-
ing Virtual Stationery from the shortcut menu. This dialog allows you to select the image for the front 
and back of the media and specify the position of the image.

Note: By default media backgrounds are omitted from the output (because in the end, the pre-
printed paper will have this imagery). In case you are printing on blank paper you could print this 
background image together with the document by selecting the Print Virtual Stationery option 
in the Advanced section of the Print Wizard interface.
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Working with style sheets
You’ve learned how to navigate the content and how to apply formatting to selected text. The Outline 
pane revealed two subheadings that inherited the Heading 2 style from MS Word. Both the Outline 
pane and the breadcrumbs show the underlying HTML element. These Heading 2 subheadings are 
identified by the <h2> element.

To change these headings into something else (a paragraph, or a heading of another level) you can 
use the Formatting toolbar (see the picture) or the menu: Format > Paragraph Format.

In order to change the way a heading or paragraph looks, you could select its text and use the toolbar 
buttons or open the Formatting dialog: choose Format > Text… This is called 'local formatting'.

However, instead of formatting elements locally, it is recommended to use Cascading Style Sheets 
(CSS).
Style sheets are stored in a central location. They may save you a lot of time as you don’t need to select 
text throughout the document and apply formatting to each instance manually: you can add a style rule 
to a style sheet to format several elements at the same time. Style rules ensure that formatting is 
applied consistently.
In Connect Designer, style rules can be made using the Stylesheets dialog. 

1. Creating a style rule
In this exercise you will learn how to change the formatting of the level 2 headings with CSS, via the 
Stylesheets dialog.

 1. Choose Edit > Stylesheets…, to make the Stylesheets dialog appear.

 2. The selected context is Global. Style rules created in this context will apply to all context types. 
Use the drop-down to select the Print context. Style rules created for a specific context (in this 
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case, the Print context) will only be applied to sections in that context.

 3. Click the Plus icon to create a new style rule.

 4. Enter h2 in the Selector field. The selector defines to which elements in the document the rule 
applies. By stating h2 the rule applies to all level 2 subheadings.
The Selector field in the New Rule dialog accepts any standard CSS selector:             

 l an HTML tag (for example, type p to select all paragraphs)

 l a class (for example: .burgundy)

 l an ID (for example: #intro)

 l a combination of CSS selectors (for example: div#intro p.burgundy, to select all para-
graphs with the class burgundy in a <div> that has the ID intro); see http://www.w3schools.-
com/cssref/css_selectors.asp.

Note: In an HTML file, each ID should be unique. This means that a particular ID should be 
used only once in each section. A class can be added to multiple elements, even if those 
elements are of different types.

 5. Make the following changes to the style properties on the Type tab:    

 l Font size: 12pt

 l Color: Click the Color Picker icon next to the Color field and enter the following values (or 
use the eyedropper tool to pick the color of the subject line in the letter):           
CMYK: Cyan 0, Magenta 92, Yellow, 77, Black 22

 6. Click OK to close the Color Picker dialog and go to the Spacing tab.

 7. Make the following settings in the Margin section:    

 l All sides: uncheck

 l Margin bottom: 3pt

 8. Click OK to create the style rule.
Note that the lower part of the Stylesheets dialog shows the style declarations for the selector in 
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the upper part of the dialog.

 9. Click Save to store the rule with the template. The properties are applied to the subheadings.

 10. Place the cursor in one of the headings and take a look at the Styles pane at the top right: the 
style rule that you made is visible here. 

Note: The Styles pane also shows a link to where the style rule is located: in the CSS file 
context_all_styles.css. You could click the link to open the CSS file in the workspace and 
edit it directly.

2. Editing a style sheet
As you’ve seen in the Stylesheets dialog, a rule consists of a selector and a set of declarations.

The selector points to the HTML element you want to style.
The style-set contains one or more declarations, each ending with a semicolon. A declaration includes 
a property name and a value, separated by a colon.
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In this exercise you will change a CSS file directly, instead of via the Stylesheets dialog. As you gain 
more knowledge of CSS, this option will become increasingly convenient.

This letter is designed to fit on one page. But in a longer letter, the signature image and the name of the 
representative might sometimes end up on different pages. These elements should stick together. This 
can be arranged using the CSS page-break-after property.

 1. Select the paragraph that contains the name and title of the representative: place the cursor in 
the paragraph and then click on p in the breadcrumbs.

 2. Give the paragraph an ID: on the Attributes pane, type rep in the ID field. This ID will be used as 
the selector of the style rule.

 3. On the Resources pane, expand the Stylesheets folder and double-click context_print_
styles.css. The file opens in the workspace. As you can see, it already contains the selectors 
and style rules that were added via the Stylesheets dialog.

 4. Add the following style rule:             

#rep {

  page-break-before: avoid;

 }

Tip: Type Ctrl + Space to get suggestions. As you start typing, the list of suggestions will 
get shorter. Use the arrow keys to select a suggestion and press Enter to insert it in the 
style sheet.

 5. Save the file: press Ctrl + S.
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Using Master Pages
Each new Print template automatically gets one Master Page. A Master Page is a layer between the 
Media and the pages in Print sections. Master Pages are meant to contain headers, footers and all 
other elements which aren’t part of the text flow. With Master Pages you can make elements appear on 
multiple pages, or only on the first or last page of the section. Unlike the Media, Master pages are prin-
ted when the template is merged with a record set.

1. Adding an element to a Master Page
This exercise shows how to add an element to a Master Page.

 1. Open Master page 1: on the Resources pane, open the Master pages folder and double-click 
Master page 1. The Master Page is opened in the workspace.             

 2. Add a Positioned Box by clicking the Insert Positioned Box icon on the toolbar.

Tip: Elements on a Master page aren’t part of the text flow, so they need to stay in place. 
Therefore they have to have an absolute position, or be located in another element that 
has an absolute position. 

 3. Position the box to the top right of the page, in a way that it doesn’t overlap with the letterhead. 
Clicking on one of the borders of the box allows you to drag it. Click on one of the small squares 
to resize it. Alternatively, you could type its top, left, width and height on the Attributes pane, for 
example:
Y-offset: 1.8in
X-offset: 5.55in
Width: 2.2in
Height: 0.8in 

 4. Click inside the box and type the following text:

OL Mobile
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2030 Pie-IX Blvd, Suite 500
Montreal (QC) Canada, H1V2C8
www.olmobile.com

Tip: Click Shift + Enter to insert a line break.

 5. Reopen the Print section by double-clicking it. You will see that the address is now shown on 
every page of the Print section.

2. Adding and applying Master pages
The address on the Master Page appears on all pages of the section, but it only needs to be visible on 
the first page of the section. The solution is to add a second Master Page and to apply each Master 
Page to different pages, or rather ‘sheet positions’. This exercise shows how to do that.

 1. On the Resources pane, right-click the Master pages folder and select New Master Page.             

 2. A small dialog will appear with a name for the new master page (Master page 2). Click OK to 
accept the proposed sizes and add the new Master Page.

 3. On the Resources pane, open the Context folder, and in the Print folder, right-click the section 
(Section 1) and select Sheet Configuration…

 4. Uncheck the option Same for all positions. In this context, a position is the position of a sheet 
in the output. A sheet can be the first or the last sheet in the output, or one of the sheets in 
between. If the output consists of one sheet, it has the ‘Single sheet’ position.             

 5. For the front of the First Sheet and Single Sheet position, select the Master Page with the 
address box: use the Master Page Front drop-down to select Master page 1. (When Duplex – 
double-sided printing – is not enabled, you can only select a Master Page for the front.)

 6. For the Middle Sheet(s) and Last Sheet position, select Master page 2 as the Master Page for 
the front.

 7. Click OK to close the dialog and apply the changes.

 8. Toggle to Preview mode to verify that the Master pages are displayed correctly. 
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Using scripts and snippets
So far you have been using wizards to create personalized and dynamic content. The wizards are dia-
logs that hide the underlying script code. You can see this in any script wizard when you click the 
Expand button. This button opens the Script Editor which lets you edit the script directly.

The Script Editor allows to select elements in a template and apply an action to them. The selection is 
not limited to items inside sections; scripts may also control elements on master pages, email headers, 
etc.

Actions include changing styles and formatting, hiding/removing elements, replacing elements and 
injecting content (from HTML snippets, for example).

In Connect Designer all scripts are written in JavaScript, a scripting language that was originally 
developed to create interactive web pages. For this chapter you don’t need to know anything about 
JavaScript – you may copy the script - but it will pay off to learn the basics. Many books are published 
about this subject and many websites provide tutorials, code snippets and other resources (Google is 
your friend).

This chapter explains how to write your own script, without a wizard. The script will insert part of a snip-
pet (a small HTML file) in the template, depending on the value of a field in the record set.

1. Importing a snippet
The company, OLSG-Mobile, has several offices. This exercise shows how to import a snippet that con-
tains the addresses.
Snippets are imported in much the same way as images are imported.

 1. Locate the snippet olsg_address.html, provided with this tutorial.

 2. Copy the snippet into the Snippets folder in the Resources pane. (If asked, click OK to accept 
the encoding.)

 3. Double-click the new snippet to open it in the workspace.

 4. Click the Source tab at the bottom of the workspace, to view the HTML of the snippet.

Every paragraph in this snippet has an ID that is identical to one of the values used in the province data 
field, as you can see in the Data Model pane. In the following exercise these ID’s will be used to select 
a paragraph from the snippet and insert that in the template.

2. Inserting a snippet via script
In this exercise you will learn how to write a script that fills the box on Master page 1 with a variable 
address: the address in Ontario or the address in Québec. A customer living in Ontario should see the 
Ontario address. All other customers should see the address in Québec. The two addresses are stored 
in the snippet that you imported in the previous exercise.

Page 28



 1. Open the Master Page that contains the address box.             

 2. Select the box (div) using the breadcrumbs.

 3. Give the box an ID: on the Attributes pane, in the ID field, type office.

 4. Right-click the box. Make sure not to right-click the text inside it.             

 5. Choose New Script from the shortcut menu. The Script Editor appears. The name and selector 
of the script are added automatically. The ID of the box is used as the script’s selector.

 6. Change the script name to Change Company Address.

 7. Add the following script. 

var office = loadhtml("snippets/olsg_address.html", "#" +
    record.fields.province);
results.html(office);

In Preview mode and when output is generated, this script will read the value of the province 
field in the current record. It will load the paragraph that contains the address of the office in that 
state value from the snippet and insert that in the template. 

Note: The functions used in this script are documented in the Designer Scripts API in the 
online documentation.

 8. Click OK and switch to Preview mode to see if the correct address appears in the template. 
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