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Designing an invoice
This step by step walkthrough will teach you how to create a new basic invoice from scratch. It will 
explain common techniques that are applicable to other document types too.

Connect Designer lets you create and design print documents, web pages and emails in one tool. 
Every aspect of a document can be easily personalized thanks to its feature-rich and user-friendly inter-
face.

The file format of the templates is HTML, the main markup language for web pages and e-mail mes-
sages. When exploring the user interface you will see several items that reveal this underlying tech-
nology. You will be able to work with the application without knowing HTML, but for users who are 
advanced in HTML and related technologies and standards like JavaScript and Cascading Style 
Sheets, the user interface does include the appropriate features.

This tutorial will teach you to create a new basic invoice from scratch. It will explain common techniques 
that are applicable to other document types too. But there is more to learn. To discover new ways and 
enhance your skills, please visit https://olresourcecenter.uplandsoftware.com and the Help (PReS Con-
nect or PlanetPress Connect).

This walkthrough is meant to be used with OL Connect Designer 2022.2 and later versions.

Template requirements
Here are the requirements for the invoice template that needs to be created:

 l The template contains a letterhead. Which color it has, depends on the hobby of the receiver: 
green for skating, purple for skiing.

 l The general invoice information, like the invoice number and the due date, should be printed at 
the top, under the letterhead.

 l The invoice data has to be printed in a table. The table should contain a transport line if it runs 
over two or more pages. The pages should be numbered.

 l The company has several offices. The sender’s address should be the office that is nearest to the 
receiver of the invoice.

 l To fill any remaining white space a picture should be printed. Which picture is printed depends on 
the hobby of the receiver. If no white space remains, the picture should not be printed.

The generated invoice will look similar to this picture:

Page 5

https://olresourcecenter.uplandsoftware.com/blog/
https://help.uplandsoftware.com/objectiflune/en/pres_connect/2022.2/Home.html
https://help.uplandsoftware.com/objectiflune/en/pres_connect/2022.2/Home.html
https://help.uplandsoftware.com/objectiflune/en/planetpress_connect/2022.2/Home.html


Page 6



Creating a template
The exercises changes this lesson introduce the concepts of sections, content and formatting. You will 
also learn how to navigate the content.

1. Creating a template
In this exercise you will learn how to create a new document for print. A Print template can be printed to 
a printer, to a file, or it can be attached to an email designed in Connect Designer.

 1. Launch the Designer application by double-clicking the application icon.

 2. Choose File > New... > Template > Print Template and click Next, or in the Welcome screen, 
under Create/Open,  click New Template and choose Print. The New Print Template wizard is 
shown. 
The dialog lets you enter parameters for the new document, which includes its page size, the 
page margins and the number of sections. A section contains one or more pages. Text will flow 
automatically from one page to the next.

 3. Make the following settings:         

 l Page size: Letter

 l Margin Top: 1.4in

 l Margin Left: 1.6in

 l Margin Bottom: 1.2in

 l Margin Right 0.8in

 4. Click Finish. The new document is shown in the main area of the user interface.

 5. On the Resources pane at the left, expand the Context, and then the Print folder. Right-click 
Section 1 and rename the section to Invoice.

 6. To save the document, choose File > Save As. The Save Template dialog box displays.

 7. Navigate to a folder (the folder where you unzipped the Walkthrough files, for example), enter My 
OLSG Invoice.OL-template in the File name field and then click Save.

Tip: It is also possible to create a new Print template by importing a Microsoft Word file via the 
menu (File > Import > Word).

2. Importing images
In this exercise you will learn how to import images into a template. Images can be static elements or 
they can be dynamically replaced by scripts based on a data field. They can also be used as a dynamic 
element to fill white space, as you will see in a later exercise.
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 1. In case the Resources pane is not shown, choose Window > Show View > Resources.

 2. Locate the images folder provided with this tutorial.

 3. Copy OLSG_letterhead-green.pdf (right-click, then select Copy) to the Images folder in the 
Resources pane (right-click > Paste).

3. Adding a Virtual Stationery background
In this exercise you will learn how to set a PDF image as a background to emulate pre-printed paper. 
After specifying a so called "virtual stationery image" you can preview the pre-printed media and place 
the content in the correct position. The image will be repeated for all pages that use this media.

To set a PDF as media:

 1. Locate the file OLSG_letterhead-green.pdf in the Images folder on the Resources pane (the 
image was added in the previous exercise).

 2. Drag OLSG_letterhead-green.pdf to the Media 1 entry in the Media folder on the Resources 
pane. The first page in the PDF will be set as the front side image of the media.
          After adding the image to the Media you will see that the image appears in the background of the 
page(s).

What if you dropped the wrong PDF on the Media or want to change it? The Media properties dialog 
allows you to delete a PDF file from a Media. It also lets you select an image for both the front and back 
of the Media and specify the position of the image. 
To open the dialog, right-click the Media 1 entry and select Virtual Stationery from the shortcut menu.

Note: By default, Media backgrounds are omitted from the output (because in the end, the pre-
printed paper will have this imagery). In case you are printing on blank paper you could print this 
background image together with the document by selecting the Print Virtual Stationery option 
in the Advanced section of the Print Wizard interface or in an Output Creation Preset.

4. Adding text and applying basic formatting to it
In Connect Designer every print section consists of a main text flow. This is the area defined by the 
page size and margins. The margin guides are shown in light blue.

 1. Place the cursor at the start of the document.

 2. Type INVOICE.

 3. Select the word INVOICE and change the style from Paragraph to Heading 1 using the For-
matting toolbar.

 4. Press Enter and type Terms and Conditions on the next line. Change the style to Heading 3.
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 5. Press Enter and then click the Insert Lorem Ipsum toolbar button to enter dummy text.

 6. Select one word in the dummy text and use the Bold toolbar button to make it bold. 

Alternatively you could copy-paste text from a text processor, or from a Microsoft Word file. Basic style 
characteristics specified in Word travel with the content to Connect Designer. Formatting options like 
bold, italic and formats like Heading 1, Heading 2 are maintained.

5. Exploring the document
In this exercise you will learn how to explore and quickly select elements on the page using the Outline 
pane and the breadcrumbs. The Outline pane at the left shows a hierarchical tree structure of the 
pages and their elements. Advanced users will refer to this as the HTML Document Object Model or 
DOM.

 1. The Outline pane is located in the same area as the Resources pane. Click the Outline tab to 
open it. If the Outline tab isn’t visible at all, choose Window > Show View > Outline. 
The Outline pane lists the elements that are currently present in the document: two headings and 
one paragraph. The subheadings are marked with <h1> and <h3> and the paragraph is rep-
resented by the <p> entry in the tree.  
A <p> element defines a paragraph in HTML. Other common HTML elements are: 

 l h1 through h6 (headings)

 l img (image)

 l table

 l tr (table rows)

 l td (table data: table cells)

 l span (a piece of styled text inside another HTML element)

 l div (a box).

 2. Click the <p> element in the Outline pane. The main document window jumps to that paragraph 
and shows an outline around its contents. The paragraph is now selected and you can see a p in 
the bar below the tab that holds the title of the document. This line is referred to as the bread-
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crumbs.

 3. Click on INVOICE in the text. Note that both the Outline pane and the breadcrumbs are updated 
to show that the currently selected element is h1.

 4. Click on the word under Terms and Conditions that you’ve bolded. The breadcrumbs show that 
the selected, bold word is located inside a paragraph: p > b > ~contents.

 5. Now click on the p in the breadcrumbs. Note that the paragraph gets selected in both the text and 
the Outline pane. 

 6. With the paragraph still selected, select font-size 9pt in the Formatting toolbar to reduce the size 
of the Lorem ipsum text.

 7. Save the template.
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Adding the dynamic invoice data
The Dynamic Table feature provides an easy way to lay out rows and columns for line item information 
such as the description of a product, the unit price, total price, quantity etc. Table rows are auto-
matically inserted based on the number of rows in a detail table. Once the table reaches the bottom of 
the page a new page is inserted automatically. The invoice will continue on the next page. Headers and 
footers can be repeated across pages, and subtotals, transport lines and the invoice’s total can be 
added automatically.

In this exercise you’ll learn how to insert a Dynamic Table to lay out the information of a detail table 
stored in the data set.

1. Adding the dynamic table
 1. Toggle to the Design mode and place the cursor at the beginning of the heading 'Terms and 

Conditions'.

 2. Choose: Insert > Table > Dynamic Table... The Insert Dynamic Table dialog appears.

 3. Change the value of the ID field to: invoice-data.

 4. Make sure that the Detail table field reads products. This is the detail table in the data that 
holds the invoice line items.

 5. From the Location drop-down, choose Before element. This causes the table to be inserted dir-
ectly before the level 3 heading (h3).

 6. Click Next. The Dynamic Table Builder is shown. 
It contains one 'row' which is associated to the selected detail table. The row will be repeated in 
the output (or in Preview mode) as many times as necessary to display all the records in the asso-
ciated detail table. 
The 'fields' - cells in the table - correspond to data fields in the detail table.

 7. Delete the "Ordered" and "BackOrder" fields by clicking on the red cross. The following fields 
should be listed:         

 l ProdNumber

 l Description

 l UnitPrice

 l Shipped

 l Total

The fields will appear in the table in the order in which they are listed here. To rearrange them, 
you can drag and drop them by clicking to the left of a field.
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 8. Without currency signs the values in the Unit Price and Total columns will look better. Change the 
Format for these fields to Currency No Symbol. 

 9. Note how the alignment is set for text in different kinds of fields: text is left-aligned, amounts in 
currency fields are right-aligned and numbers are centered. 

 10. Click Next. The Dynamic Table Options  page is shown. The options on this page let you add sub-
totals to the footer and transport lines (in case the table runs across multiple pages).

 11. Check the Calculate Subtotals item. 

 12. Verify that Total is selected as the data field that will be used to calculate the subtotals and 
totals.

 13. Check Show subtotal lines before page break options to have subtotals shown before page 
break and after end of the table.

 14. Click Next. The predefined table styles are shown.                  Select the 6th table style (the second from the 
top right) and click Finish to insert the table.
How to further style the table is demonstrated later in this walkthrough.

The table is inserted at the current cursor position. It has a column for each of the selected data 
fields. The cells in the body table row, between the header and footer rows, each have an expres-
sion (the name of a data field, enclosed in double curly brackets). The currencyNoSymbol Format 
Helper formats the amounts as a currency without a currency sign.

Tip: Click the Show Edges button on the toolbar to show the edges of the table with thin 
green lines. These lines are visible in Preview mode, but will not be printed.

 15. Toggle to Preview mode. You will see that the body table row is repeated for each detail record 
and that the expressions are replaced with the corresponding values.
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Note that there is only one subtotal row on each page in output and in Preview mode, whereas in 
Design mode, you can see two. The bottom footer row is only shown on the last page. The row 
above it is shown on all other pages, if the table runs over multiple pages. 

2. Adding labels and rows
At this point the table shows the basic information of the invoice line items. In this exercise you’ll learn 
how to add additional rows and information to this table.

To add a label to the subtotals in the footer:

 1. In Design mode, place the cursor in the cell next to the @Total@ cell in the first row of the footer 
of the table. Type Subtotal. 

 2. Do the same in the bottom footer row.

Now add additional rows for the tax and invoice total: 

 1. Right-click one of the cells in the bottom row and choose Row > Insert Below from the shortcut 
menu. Repeat this to add a second row. 

 2. On the Outline pane, click on the second to last footer row (the third <tr> in <tfoot>).

Tip: Alternatively you click in the row and then on tr in the breadcrumbs: ... > tfoot > tr > td 
... 

 3. On the Attributes pane, change Show Row to: At end of table. This prevents that a row is 
shown on every page if the table runs over multiple pages. 

 4. Repeat the previous step for the last footer row. 

 5. Place the cursor below the last Subtotal cell and type: VAT. 

 6. Move the cursor one row down and type: Total inc VAT. 

 7. Locate the InvTaxTotal data field in the Data model panel and drag this field into the cell next to 
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the VAT cell.

 8. Drop the InvTotal data field in the last table cell of the table.

Now, in Preview mode the table will look like this:
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Formatting the Dynamic Table
This chapter explains how to format a Dynamic Table. You will not only change the text and text align-
ment, but also change the column widths, borders and background colors. 

Note: These changes are best made in Design mode.

1. Formatting text and currencies
In this exercise you will change some labels, text alignments and the formatting of amounts of money. 
Formatting text in a Dynamic Table is no different from how it is done in a Standard Table.

 1. The headers of the columns contain the name of the respective data fields. In Design mode, 
change them to proper headings: change ProdNumber to Number, UnitPrice to Unit Price and 
Shipped to Quantity.

 2. Select the first Subtotal label and click the Bold icon on the toolbar. Then set the text alignment 
of the cell to the right by clicking the Align Right icon on the formatting toolbar.

 3. Do the same with the other labels in the footer: Sutbtotal, VAT and Total inc VAT.

 4. Toggle to Preview mode to verify your changes. The table should look like the image below:

We have already set the format for the Unit Price and Total fields when adding the table. To change the 
formatting of the subtotals after adding the table: 

 1. In Design mode, click on the cell.

 2. On the Attributes pane, select the desired format from the Format drop-down.

If you would not want to display the currency sign  in the VAT and Total inc VAT fields, click in the cell 
and replace the currency Format Helper with currencyNoSymbol.
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2. Changing column widths
The product descriptions are rather long. It would be best if most of them would fit on a single line. This 
can be achieved by changing the column widths.

 1. In Design mode, hover the mouse between the Number and Description columns. The cursor 
changes to a column resizer icon.

 2. Click and drag the column separator to the left. Then resize the other columns, from right to left, 
dragging the separator to the right. 

 3. Toggle to Preview mode to see the effect. You will see that the widths could be improved in 
columns where the actual data are less wide than the placeholders. 

 4. Toggle to Design mode, click in the field that holds the Number label, and on the Attributes 
pane, in the Geometry section, set Width to a smaller percentage, e.g. 10%.

 5. Toggle to Preview mode and back to Design mode, and change the widths of cells in the header 
row until all labels and (most) line items fit on a single line. 

 6. To ensure that the widths can't be changed accidentally, we will disable the option to resize the 
table. Select the table: click somewhere in the table, and then click on table #invoice-data.t-
able--light in the breadcrumbs. 

 7. On the Attributes pane, uncheck the option Allow Resizing. (You may have to scroll down  in 
the Attributes pane to see this option.)

3. Using the Formatting dialog
In this exercise you will learn how to use the Table Cell Formatting dialog. The next exercise shows 
how to use the Stylesheets dialog.

 1. In Design mode, place the cursor in the first cell of the header row. Press the Shift key and click 
the last cell in this row. The cells of the header row are now selected.

 2. Right-click one of the selected cells and select Cell… (note the dots) from the contextual menu. 
The Table Cell Formatting dialog appears.
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 3. Click the Border tab.

 4. Deselect the Same For All Sides option and make the following settings for the Top border:         

 l Width: 1pt

 l Style: solid

 5. Click the small square next to the Color field. The Color dialog appears. Under RGB, enter:
            R: 144, G: 144, B: 144.

 6. Click OK to close the Color dialog.

 7. Click OK again to apply the border settings to the selected cells.

 8. Select the cells in both Subtotal rows and open the Table Cell Formatting dialog.

 9. Click the Background tab. Click the small square next to the Color field. The Color dialog 
appears. 

 10. Under RGB, enter: R: 230, G: 230, B: 230. Click OK to close the Color dialog and OK again to 
close the Table Cell Formatting dialog. The table now looks like this:

   

4. Using the Stylesheets dialog
Horizontal lines make it easier to read the data and they make the table look better. This exercise 
shows how to change borders and background colors of table cells with CSS (Cascading Style Sheets), 
via the Stylesheets dialog. 

 1. Choose Edit > Stylesheets…, to make the Stylesheets dialog appear.

 2. From the Context drop-down, choose Print, to make the styles apply to Print sections only.

 3. Click the Plus icon to create a new style rule.

 4. In the dialog that appears, type td in the Selector field. The selector defines to which elements in 
the document the rule applies. By stating td the rule applies to all table cells. In HTML, a table 
data cell is a <td>.

 5. Click the Border tab.
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 6. Deselect the Same For All Sides option and make the following settings for the Top border:         

 l Width: 1pt

 l Style: solid

 7. Click the small square next to the Color field. The Color dialog appears. Under RGB, enter:
            R: 144, G: 144, B: 144.

 8. Click OK to close the Color dialog.

 9. Click OK to close the rule editor.
The top part of the Stylesheets dialog lists selectors (up to now there’s only one: td) and the pre-
view in the bottom part lists all style rules for the selected selector.          In the style rule that you’ve 
just made, “border-top” is the CSS property, and “1pt solid rgb(144, 144, 144)” is the value 
assigned to that property.

 10. Click Save to close the Stylesheets dialog.

 11. Toggle to Preview mode and look carefully at both tables in the template: the standard table with 
the invoice and address information and the Dynamic Table.

As you can see, the newly added style rules don’t just affect cells in the Dynamic Table. They 
also apply to the table with the invoice information. This is because the selector selects all cells in 
all tables. So, the selector has to be more specific.

 12. Reopen the Stylesheets dialog and select the context: Print.

 13. Select td and click the Edit button (with the blue pencil).
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 14. Change the selector to #invoice-data td. Save the settings. Now, the style rule only applies to 
table cells inside an element that has the ID: invoice-data – which is the Dynamic Table.

 15. Create a new rule-set: click the Add button, type the selector #invoice-data tfoot and on the 
Type tab, check Bold. This bolds all text in all footer rows of the Dynamic Table.             

Tip: The options in the Rule editor represent the most frequently used CSS properties. If a 
property is not available here, click the Advanced button. In Advanced mode you can add 
a style rule by typing a CSS property (at the left) and its value (at the right).

 16. Save the settings. In Preview mode, the table should now look like this:

 17. A different background color and text color will make the total amount of the invoice stand out. 
Coloring two cells with one style rule is easy if they have the same class. 
In Design mode, click in the cell that contains the text Total inc VAT and use the breadcrumbs or 
the Outline pane to select the cell (td). 

 18. On the Attributes pane, in the Class field, type invtotal. 

 19. Repeat the previous two steps for the cell that contains the @InvTotal@ placeholder.

Note: Elements can have more than one class. Separate class names by a space.

 20. Open the Stylesheets dialog, and select the context: Print.

 21. Click the Add button to create a new style-set.

 22. As selector, type .invtotal (note the dot). This will make the new rules apply to any element that 
has the class invtotal.            

 23. On the Type tab, in the Color field, type White. This turns the text color into white.

 24. Click the small square next to the Background Color field. The Color dialog appears. Under 
RGB, enter:
            R: 144, G: 144, B: 144.
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 25. Click OK to close the Color dialog. Now the table looks like this:

5. Editing a style sheet
As you’ve seen in the Stylesheets dialog, a rule consists of a selector and a set of style rules.

The selector points to the HTML element you want to style. The style-set contains one or more declar-
ations, each ending with a semicolon. A declaration includes a property name and a value, separated 
by a colon.

In this exercise you will add padding to table cells and change the font size by editing a CSS file dir-
ectly, instead of via the Stylesheets dialog. As you gain more knowledge of CSS, this option will 
become increasingly convenient.

 1. On the Resources pane, expand the Stylesheets folder and double-click context_print_
styles.css. The file opens in the Workspace. You will see that it already contains the selectors 
and style rules that were added via the Stylesheets dialog.

 2. Add the following style rules to the style-set for #invoice-data td:

font-size: 10pt;

padding: 6pt 2pt;

Padding is the margin inside an element, in this case, a table cell. 

 3. Press Ctrl + S to save the style sheet.             

Note: Never edit a CSS file in the workspace and via the Stylesheets dialog at the same 
time!

 4. Click the My OLSG Invoice tab and toggle to Preview mode. Because of the padding and the 
changed font size, you will need to resize the columns to make most product descriptions fit on 
one line again. (Enable the Allow Resizing option first.)
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The final table layout will look similar to the following image:
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Adding a variable address (using a snippet, master 
page and script)
The only thing that’s still missing in the invoice is the address of the sender. The sender is a company 
that has offices in different cities. All addresses are available in one snippet. In this exercise you will 
learn how to write a script that inserts part of a snippet in the template, depending on the value of a 
field in the record set.

1. Importing a snippet
Snippets are small HTML files. They are imported in much the same way as images are imported.

 1. Locate the snippet olsg_address.html, provided with this tutorial.

 2. Copy and paste the snippet into the Snippets folder in the Resources pane.

 3. Click OK to confirm that the encoding is UTF-8.

 4. Double-click the new snippet to open it in the Workspace.

 5. Click the Source tab at the bottom of the Workspace to view the HTML of the snippet. 
Every paragraph in this snippet has an ID that is identical to one of the values used in the 
StateAbbrev field, as you can see in the Data Model pane. These IDs will eventually be used to 
select a paragraph from the snippet and insert that in the template.

 6. Close the snippet by closing the tab.

2. Inserting a Box on the Master Page
In this invoice, the letterhead is the same on every page and the address should appear on every page 
as well. The best place for this type of elements is the Master Page. In this exercise you will learn how 
to create a Box on a Master Page.

 1. On the Resources pane, expand the Master pages folder.

 2. Double-click Master page 1 to open it.

 3. Click the Insert Positioned Box toolbar button.
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 4. Drag and resize the Box to fit on the lowest part of the page, as in this image:

 5. Give the Box an ID: on the Attributes pane, in the ID field, type olsg-address. This will be used 
as the selector of the script. In the box, you could type a placeholder, for example {address}, but 
that isn’t really necessary. In this case the script will simply replace all of the contents of the box.

 6. Save the Master Page (Ctrl S) and reopen the Invoice template (on the Resources pane, 
expand Contexts, Print and then double-click the Invoice template).

Note: Although in this walkthrough we will only use one Master Page, it is common to have more 
than one Master Page and apply different Master Pages to different pages in a template. This is 
called Sheet Configuration. To open the Sheet Configuration dialog, open the Resources pane, 
expand Contexts, then Print; right-click the Invoice template and select Sheet Configuration.

3. Write a script that uses a snippet
In this exercise you will learn how to write a script that fills the box on the Master Page with a variable 
address. The addresses are stored in a snippet.

 1. Right-click the box and choose New Script from the shortcut menu. The Script editor appears. 
The selector of the script - the ID of the box - is added automatically.

 2. Change the script name to Change Company Address.

 3. Add the following script.
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var office = loadhtml("snippets/olsg_address.html", "#" + 
    record.fields.StateAbbrev);
results.html(office);

In Preview mode and when output is generated, this script will read the value of the StateAbbrev 
field in the current record. It will load the paragraph that contains the address of the office in that 
state value from the snippet and insert that in the template. 

 4. Click OK. The script appears on the Script pane in the Standard scripts folder.

 5. Switch to Preview mode to see if the correct address appears in the template.
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The finishing touch
1. Adding page numbers
Invoices consist of a variable number of pages, so they need to have page numbers. This exercise 
shows how to add page numbers to a template.

 1. Open the Master Page. The page number should appear on every page, so the best place to put 
it in is the Master Page.

 2. Add a Positioned Box and put it at the bottom right, next to the box for the company address.

 3. In the box, type Page (followed by a space).

 4. From the menu, select Insert > Special Character > Markers > Page Number.

 5. Type a space, then of, followed by a space.

 6. From the menu, select Insert > Special Character > Markers > Page Count.

 7. Click the Align Right icon on the toolbar to align this text to the right of the box.

 8. Save the Master Page.

 9. Reopen the Invoice template.

 10. Toggle to Preview mode to see if the page numbers are inserted correctly.

Tip: To change the page number format to, for example, uppercase Roman numerals (I, II, III) or 
lowercase letters (a, b, c), right-click the Invoice template on the Resources pane and select 
Numbering.

2. Using an image as a whitespace element
In this exercise you will add an image to the invoice to be used as a white space filler.

White space on an invoice can be very well used to include an advert or announcement. If there is white 
space on some invoices, but not on others, you may insert an image in the template and tag it as a 
whitespace element. A whitespace element will only be included in the output if it fits in the available 
white space on the current page.

Page 25



 1. In Design mode, add one new paragraph below the paragraph Terms and Conditions: place the 
cursor at the end of that paragraph and press Enter.

 2. Import the image: locate the images folder provided with this tutorial, and drag olsg_
whitespace_hockey_M.pdf from that folder to the Images folder in the Resources pane.

 3. Place the image in the template: drag olsg_whitespace_hockey_M.pdf from the Images folder 
to the empty paragraph. The image is inserted at the cursor position and anchored to the text. 
This means that new lines added above the image will push the image down.

 4. Select the image in the document. When selected, images can be resized by dragging the resize 
handles. Resize the image if needed. Keep the Shift key pressed while resizing to scale the 
image proportionally. 
Note that the Source field in the Attributes pane shows the path to the image e.g. “images/olsg_
whitespace_hockey_M.pdf”. In this path, "images" refers to the Images folder in the Resources 
pane.

 5. The breadcrumbs show that the selected image is inside a paragraph. Click the p in the bread-
crumbs to select the paragraph that contains the image. 

Note: Only top-level elements can be used as whitespace element. In the breadcrumbs, 
top-level elements come first.

 6. On the Attributes pane, check the Whitespace option.

 7. Switch to Preview mode and browse the records to see that the invoice only shows the image if it 
has space for it.

Note: If you want a larger distance between the text of the invoice and the whitespace filler 
image, don’t add a paragraph; that could result in an extra page. Instead, set a top margin for the 
image: 

 1. Right-click the image and choose Image…

 2. On the Spacing tab, in Margins, uncheck All sides and enter a top margin (for example, 
10px).
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3. Switching images dynamically
In this exercise you will learn how to write a script that replaces one image by another, depending on 
values in the record set.

The Marketing department has provided four images:

 l The hockey advert should only be presented to people who like hockey; men should get the 
green version (olsg_whitespace_hockey_M.pdf) and women the purple version (olsg_
whitespace_hockey_F.pdf).

 l Recipients whose favorite hobby is to ski should get the skiing advert; olsg_whitespace_skis_
M.pdf is for men, olsg_whitespace_skis_F.pdf for women.

 1. Import the extra images: locate the images folder provided with this tutorial and drag the images 
that are needed to the Images folder in the Resources pane.

 2. Click the image in the template to select it and give it an ID: on the Attributes pane, in the ID 
field, type olsg-banner.

 3. Right-click the image and choose New Script from the shortcut menu. The Script editor appears. 
The selector of the script is added automatically.

 4. Change the script name to Switch Banner.

 5. Add the following script:

if (record.fields.FavHobby == "skate") {
    results.attr("src", "images/olsg_whitespace_hockey_" + 
        record.fields.Gender+".pdf");
} else {
    results.attr("src", "images/olsg_whitespace_skis_" +
        record.fields.Gender+".pdf");
}

Scripts start by performing a query: they scan the template to find all elements that match the 
specified selector. This script will look for an element that has the ID olsg-banner. Then, fol-
lowing the conditions, it attributes a different source to the results of that query – which in this 
case is the image. The "F" or "M" at the end of the images' name can be returned dynamically by 
the Gender data field

 6. Click OK to close the dialog and toggle to Preview mode to see if the script works as expected.

4. Switching Media dynamically
The Marketing department has also provided a new letterhead, to match the images that are colored 
purple. In this exercise you will use that as a second Media and create a script to switch the Media 
based on a data value.
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 1. Import the new letterhead: locate the images folder provided with this tutorial and drag olsg-let-
terhead-letter-purple.PDF to the Images folder in the Resources pane.

 2. Right-click the Media folder in the Resources pane and select New Media. The Media Prop-
erties dialog appears.

 3. On the Virtual Stationery tab, check the Front option and click the Select Image icon.

 4. Select olsg-letterhead-letter-purple.PDF from the list of resources and click OK. 

 5. Click OK to create the new Media entry.

 6. Right-click the Media 1 entry and select Rename. Rename the Media to Media_green.

 7. Rename the second Media entry to Media_purple.

 8. Open the Sheet Configuration dialog: right-click the invoice and select Sheet Configuration.

 9. Click the Edit Script icon. 
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 10. The Edit Script dialog appears. Change the name of the script to Switch Media.

 11. Replace the existing script with the following code. It contains a condition to toggle the Media 
when the hobby of the recipient is skating:                 

if (record.fields.FavHobby == "skate") {
    results.attr("content","Media_green");
} else {
    results.attr("content","Media_purple");
}

 12. Click OK to create the script entry. The entry is added to the Scripts pane.

 13. Click OK to close the Sheet Configuration dialog.

 14. Toggle to the Preview mode and browse through the records to see if the script works as expec-
ted.

5. Keeping elements together
While browsing the records in Preview mode you may have noticed that sometimes the heading "Terms 
and conditions" and the paragraph beneath it are on different pages. These two elements should stick 
together. This can be arranged using the CSS page-break-after property.

 1. Choose Edit > Stylesheets… to make the Stylesheets dialog appear.

 2. From the Context drop-down, choose Print.

 3. Click the Plus icon to create a new style rule.

 4. In the dialog that appears, type h3 in the Selector field. This means that the rule will apply to all 
level 3 headings.

 5. Click the Formats tab.

 6. In the Breaks section, from the After drop-down, choose avoid.

 7. Reduce the space between the heading and the paragraph: on the Spacing tab, in Margins, 
uncheck All sides and add a margin of 2px to the bottom of the heading.

 8. Click OK to close the Rule editor.

 9. Click Save to close the Stylesheet editor and go to Preview mode to check the effect of the rules.
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The invoice is now ready. The result should look similar to this:
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