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About this Guide
This guide describes the procedures for setting up integration between Salesforce.com and Tenrox, as well as 
mapping, importing and exporting objects between Tenrox and Salesforce. This guide is used to integrate 
Salesforce.com with the following Tenrox releases:

 Tenrox 2016 R1

 Tenrox 2015 R1, R2

 Tenrox 2014 R1, R2, R3

 Tenrox 2013 R1, R2

 Tenrox 2011 R1, R2, R3

What’s New in Tenrox

Available as of: Tenrox 2013 R2

 Salesforce Package Changes

Available as of: Tenrox 2011 R3

 Defining the Custom Integration Settings

 Mapping Existing Objects in Tenrox to Objects in Salesforce

 Defining the Tenrox Object Mapping Fields

 Mapping the Tenrox and Salesforce Object Fields

 Verifying the Status of the Imports

 Deleting or Synchronizing the Tenrox Object Mapping Entries

 Importing the Project Related Objects into the Tenrox Database

Tenrox Technical Support
The Tenrox support specialists are trained to use, configure, and troubleshoot Tenrox in your specific enterprise 
environment. If you have any questions, you can reach us by:

 Sending an email to support@tenrox.com

Tenrox Software License Agreement
The Tenrox Software license agreement was reviewed and accepted during the installation procedure of this 
software in your environment. Copyright © 2016 Tenrox. All rights reserved. You may not photocopy or share this 
document with any other party without express written permission from Tenrox.

For additional information, please contact Tenrox at:
Corporate site: www.uplandsoftware.com I www.tenrox.com

Sales email: sales@tenrox.com

Support email: support@tenrox.com

Or click Help > Contents and Index from within Tenrox.
Issue 1

Note: This guide describes the procedures for integrating Salesforce.com with Tenrox, starting from the 
Tenrox 2011 R1 release. The features described in this guide apply to all Tenrox releases unless 
otherwise indicated.
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Tenrox and Salesforce Integration

The integration of Salesforce.com and Tenrox allows the handling of financial and Customer Relationship 
Management (CRM) information in Salesforce.com and the management of people, projects and business processes 
in Tenrox. With Salesforce.com integration, users can perform the following:

 Automate repetitive tasks 

 Track time and expense actuals

 Centralize internal business process activities and generate detailed, real-time analysis reports to analyze 
operations, reduce costs, meet budget requirements, and improve project and service delivery

 Automatically map Salesforce.com objects to existing objects in Tenrox 

 Define the fields of objects associated to cases, opportunities and projects in Salesforce that are imported

 Import Salesforce.com cases, opportunities or projects as Tenrox projects 

 Define custom stored procedures that are processed before and after projects are created, updated or 
deleted in Tenrox.

 Define custom filters to filter the cases, opportunities and projects that are created, updated or deleted in 
Tenrox 

 Define the fields of cases, opportunities and projects not mapped through the user interface that should be 
imported when the cases, opportunity and projects are imported

 Set up email notifications in the event of data errors during the import process

 Define Tenrox fields that are imported into Salesforce fields
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Setting Up Integration Between Tenrox and Salesforce
For integration purposes, Salesforce.com is the master and Tenrox the slave to ensure that only one set of data 
exists in both applications. For example, if changes are applied to an object in Salesforce.com that has already 
been imported into Tenrox, then Salesforce.com (master) performs the updates in Tenrox (slave) when the object is 
re-imported. However, if Tenrox Key Performance Indicators (KPIs) are associated to the Salesforce.com projects, 
then the KPIs are tracked in Tenrox and updated in Salesforce.com. For more information, see Mapping the Tenrox 
KPIs to the Salesforce Fields. 

The integration process between Tenrox and Salesforce.com consists of the following steps:

1. Configuring the TenroxSalesforce Integration Package.

2. Setting Up the Connection Between Salesforce and Tenrox.
3. Mapping the Objects Between Salesforce and Tenrox.
4. Mapping the Tenrox KPIs to the Salesforce Fields.
5. Importing the Users and Contacts into Tenrox.
6. Setting Up the Automated (Batch) Processing.
7. Exporting the Projects from Salesforce into Tenrox.

Note: The master/slave model is a communication protocol that is used to define the primary application 
(master) that controls and updates the objects of the secondary application (slave).

Available as of: Tenrox 2011 R3, custom integration is supported; for more information, see Setting the 
Advanced Integration Options. 
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Configuring the TenroxSalesforce Integration Package

Configuring the TenroxSalesforce Integration Package
The Tenrox Integration package is installed in the Salesforce.com environment to support integration with Tenrox. 
The configuration of the TenroxSalesforce integration package consists of the following steps:

1. Installing the TenroxSalesforce Package

2. Setting Up the Project for Exports to the Tenrox Organization
3. Setting Up the Project Tabs
4. Setting Up User Integration Between Tenrox and Salesforce 

Installing the TenroxSalesforce Package
Before running the TenroxSalesforce package, contact your Tenrox representative to ensure that your base 
Salesforce.com configuration does not conflict with the package installation.

The Salesforce Package is now a Managed Package

To install the TenroxSalesforce package:

1. Copy the URL https://login.salesforce.com/packaging/installPackage.apexp?p0=04ti0000000KLer and paste it 
in your Web browser’s Address bar to access the Salesforce.com logon page.

2. Enter the Salesforce User Name and Password of the Administrator of the target Salesforce environment.
3. Managed packages is created by navigating to Setup > Create > Packages.

3a. The managed package name is set to "TenroxSalesforce".

3b. The Namespace Prefix is set to "Tenrox". This namespace becomes a prefix for any items included within 
the package.

Note: Only users with administrative rights can perform the integration setup process.

Available as of: Tenrox 2013 R2 

Salesforce Package Changes

 The Salesforce Package is now a Managed Package

 Salesforce Link Modifications

 Tenrox Application Modifications

 Upgrade Impact
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Managed Package Screen in Salesforce

The Managed Package will contain the following objects and fields:

Name API Name Type Parent Owner

Tenrox URL Settings Tenrox__UrlSettings__c Custom Settings -

Organization Name Tenrox__Organization_Name__c Custom Field 
Text(255)

Custom Settings

Tenrox Server URL Tenrox__URL__c Custom Field 
Text(255)

Custom Settings

Project Tenrox__tenrox__c Custom Object -

Account Tenrox__Account__c Custom Field 
Lookup(Account)

Project

Description Tenrox__Description__c Custom Field Text 
Area (255)

Project

End Date Tenrox__End_Date__c Custom Field Date Project

Id Tenrox__Id__c Custom Field 
Text(32)

Project

Opportunity Tenrox__Opportunity__c Custom Field 
Lookup(Opportuni
ty)

Project

Project Code Tenrox__Code__c Custom Field Text 
(32), Unique Case 
Insensitive

Project

Start Date Tenrox__Start_Date__c Custom Field Date Project

TenroxUniqueId Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

Project

Actual Billing Tenrox__KPI_Actual_Billing__c Custom Field 
Currency(10,2)

Project

Actual Cost Tenrox__KPI_Actual_Cost__c Custom Field 
Currency(10,2)

Project
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Configuring the TenroxSalesforce Integration Package

Actual Time Tenrox__KPI_Actial_Time__c Custom Field 
Number(10,2)

Project

Baseline Biling Tenrox__KPI_Baseline_Billing__c Custom Field 
Currency(10,2)

Project

Baseline Cost Tenrox__KPI_Baseline_Cost__c Custom Field 
Currency(10,2)

Project

Baseline Time Tenrox__KPI_Baseline_Cost__c Custom Field 
Number(10,2)

Project

Current Billing Tenrox__KPI_Current_Billing__c Custom Field 
Currency(10,2)

Project

Current Cost Tenrox__KPI_Current_Cost__c Custom Field 
Currency(10,2)

Project

Current Time Tenrox__KPI_Current_Cost__c Custom Field 
Number(10,2)

Project

Issues Tenrox__KPI_Issues__c Custom Field 
Number(10,2)

Project

Project Billable 
Amount

Tenrox__KPI_Project_Billable_Amo
unt__c

Custom Field 
Currency(10,2)

Project

Project Billable 
Charges

Tenrox__KPI_Project_Billable_Char
ged__c

Custom Field 
Currency(10,2)

Project

Project Billable 
Expenses

Tenrox__KPI_Project_Billable_Expe
nses__c

Custom Field 
Currency(10,2)

Project

Project Billable 
Products

Tenrox__KPI_Project_Billable_Prod
ucts__c

Custom Field 
Currency(10,2)

Project

Project Billable Time Tenrox__KPI_Project_Billable_Time
__c

Custom Field 
Number(10,2)

Project

Project Billed 
Amount

Tenrox__KPI_Project_Billed_Amou
nt__c

Custom Field 
Currency(10,2)

Project

Project Invoices Tenrox__KPI_Project_Invoices__c Custom Field 
Currency(10,2)

Project

Project Paid Amount Tenrox__KPI_Project_Paid_Amount
__c

Custom Field 
Currency(10,2)

Project

Project Payable 
Amount

Tenrox__KPI_Project_Payable_Amo
unt__c

Custom Field 
Currency(10,2)

Project

Project Payable 
Charges

Tenrox__KPI_Project_Payable 
_Charges__c

Custom Field 
Currency(10,2)

Project

Project Payable 
Expenses

Tenrox__KPI_Project_Payable_Exp
enses__c

Custom Field 
Currency(10,2)

Project

Project Payable 
Products

Tenrox__KPI_Project_Payable_Prod
ucts__c

Custom Field 
Currency(10,2)

Project

Project Payable Time Tenrox__KPI_Project_Payable 
_Time__c

Custom Field 
Number(10,2)

Project

Project Work In 
Progress

Tenrox__KPI_Project_Work_In_Prog
ress__c

Custom Field 
Currency(10,2)

Project

Risks Tenrox__KPI_Risks__c Custom Field 
Number(10,2)

Project

Name API Name Type Parent Owner
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Salesforce Link Modifications
The link within each button / link have been modified to include the custom field settings that have been added to 
the package:

Open/Publish Project (Project object):

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Tenrox__tenrox__c.Id}&extapplication=salesforce&SF
serverURL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=1&crmUserID={!User.Id} 

Open/Publish Project (Opportunity object):

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Opportunity.Id}&extapplication=salesforce&SFserverU
RL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=1&crmUserID={!User.Id}

Open/Publish Project (Case object):

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

Scope Changes Tenrox__KPI_Scope_Changes__c Custom Field 
Number(10,2)

Project

Open/Publish 
Project

btnPublishProject Custom Button Project

Milestones btnMilesotne Custom Button Project

Tenrox Portal btnPortal Custom Button Project

Project Status Report rptStatusReport Custom Link Project

Project Layout - Page Layout Project

TenroxUniqueID Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

Opportunity

Open/Publish 
Project

btnPublishProject Custom Button Opportunity

TenroxUniqueID Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

Case

Open/Publish 
Project

btnPublishProject Custom Button Case

TenroxImportFlag Tenrox__TenroxImportFlag__c Custom Field, 
Checkbox 
unchecked

User

TenroxUniqueID Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

User

TenroxUniqueID Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

Account

TenroxUniqueID Tenrox__TROXUniqueID__c Custom Field 
Text(20), External 
ID

Contact

Name API Name Type Parent Owner



© 2016 Tenrox. All rights reserved. 9

Configuring the TenroxSalesforce Integration Package

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Case.Id}&extapplication=salesforce&SFserverURL={!
API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=1&crmUserID={!User.Id}

Milestones:

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Tenrox__tenrox__c.Id}&extapplication=salesforce&SF
serverURL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=108&crmUserID={!User.Id} 

Tenrox Portal: 

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Tenrox__tenrox__c.Id}&extapplication=salesforce&SF
serverURL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=1&crmUserID={!User.Id}&Di
rectLogin=1 

Project Status Report:

https://{!$Setup.Tenrox__UrlSettings__c.Tenrox__URL__c}/Tenterprise/Core/Base/logonCRM.aspx?orgname=

{!$Setup.Tenrox__UrlSettings__c.Tenrox__Organization_Name__c}&OppId={!Tenrox__tenrox__c.Id}&extapplication=salesforce&SF
serverURL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=101&crmUserID={!User.Id} 

Tenrox Application Modifications
The following changes have been made to the Tenrox application:

 Any advanced options for Import/Update/Delete will now query against the field "Tenrox__TROXUNIQUEID__c" 
as the identifier.

 The Project object mapping will now refer to the Salesforce object "Tenrox__tenrox__c". 

Upgrade Impact
When upgrading:

 Any advanced options for Import/Update/Delete will be changed to query against the field 
"Tenrox__TROXUNIQUEID__c" as the identifier.

 The Project object mapping will be changed to refer to the Salesforce object "Tenrox__tenrox__c". 
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Setting Up the Project for Exports to the Tenrox Organization
After installing the TenroxSalesforce package, the newly created project is set up to export to the correct Tenrox 
organization.

To export the newly created project to the correct Tenrox organization:
1. Click Setup at the top of the page to open the Personal Setup page.

2. From the navigation panel, click App Setup>Create>Objects to open the Custom Objects page.
3. Click the Project link to open the Project page. 

4. Click the Custom Buttons and Links tab and then click the Edit link for the Open/Publish Project record. 

5. Edit the following URL to reflect the server path and the orgname of your organization:
https://<computername>/Tenterprise/Core/Base/
logonCRM.aspx?orgname=<organizationname>&OppId={!tenrox__c.Id}&extapplication=salesforce&SFserver
URL={!API.Partner_Server_URL_70}&SFsessionId={!User.Session_ID}&mscrmCustomizationID=1&crmUse-
rID={!User.Id}

6. Click Save to save the server and orgname.
7. Repeat steps 1 to 6 for each custom button and link.
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Configuring the TenroxSalesforce Integration Package

Setting Up the Project Tabs 
In the Salesforce.com application, users can create and customize the Project tab to extend Salesforce.com 
functionality.

To set up the project tabs:
1. Click Setup at the top of the page to open the Personal Setup page.

2. From the navigation panel, click App Setup>Create>Tabs to open the Custom Tabs page.
3. Click the New button to create a new custom object tab.

4. Select a newly defined project from the Object list and then select a Tab Style for the project.

5. Select a custom link to display a splash page the first time a user clicks the tab (optional).
6. Type a short description for the new custom tab (optional)
7. Click Next to continue.

Note: If a project is already assigned to a tab, then it is not displayed in the Object list. 
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8. Specify the user profiles for the new tab. 

 Click Apply one tab visibility to all profiles to select a single tab visibility for all the profiles.

 Click the Apply a different tab visibility for each profile to select a different tab visibility for each profile.

9. Click Next to continue.

10. Select the Include Tab check box to specify all the custom applications (apps) for the new custom tab or clear 
the Include Tab check box to select specific custom applications.

11. Select the Append tab to users' existing personal customizations check box to add the new custom tab to the 
existing user layout customizations.

12. Click Save to save the settings.
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Configuring the TenroxSalesforce Integration Package

13. Click the All Tabs icon (+) and then click Customize My Tabs to add the tab to the default display.

14. Select the application from the Custom App list.
15. Select from the Available Tabs pane which tabs will be displayed for the selected application, then click the 

Add button to add the tabs to Selected Tabs pane. 

16. Click Save to accept the settings.

Note: The tabs can be added or removed, as well as moved up or down, by selecting the appropriate 
buttons.
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Setting Up User Integration Between Tenrox and Salesforce
After the TenroxSalesforce integration package is installed, all fields are applied to at least one page layout. The 
User Page Layout page allows you to create different page layouts for displaying the user data.

To set up the user integration between Tenrox and Salesforce.com:
1. Click Setup at the top of the page to open the Personal Setup page.

2. From the navigation panel, click App Setup>Customize>Users>Page Layouts to open the User Page Layout 
page.

3. Click the Edit link to edit the page layout for displaying the user data.

4. Drag and drop the TenroxImportFlag and TenroxUniqueID from the User Layout pane to the 
Additional Information pane. 

5. Click Save to complete the Salesforce.com and Tenrox integration process. The TenroxImportFlag and 
TenroxUniqueID fields are now visible when editing or viewing user information.

Note: The TenroxImportFlag and TenroxUniqueID are required for importing users into Tenrox. 
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Setting Up the Connection Between Salesforce and Tenrox

Setting Up the Connection Between Salesforce and Tenrox
Before users can integrate with Salesforce.com, a connection must first be established between Salesforce.com and 
Tenrox. 

The set up of the connection between Salesforce.com and Tenrox consists of the following steps:

 Locating the URL in the Salesforce WSDL Document

 Setting Up the Connection to Salesforce

Locating the URL in the Salesforce WSDL Document
Before setting up the connection to Salesforce.com, ensure that a user ID and password from a valid Salesforce.com 
account is provided. The URL to access the Salesforce.com Web service is also required. The URL is located in a 
Salesforce.com Web Services Description Language (WSDL) document.

To locate the URL in the Salesforce.com WSDL document:
1. Log on to Salesforce.com. 

2. Click Setup at the top of the page to open the Personal Setup page.
3. From the navigation panel, click App Setup>Develop>API to open the API WSDL page.
4. Under Partner WSDL, click the Generate Partner WSDL link to open the Salesforce.com Partner Web Services 

API XML page.
5. Scroll to the bottom of the XML page and then find <soap:address location="URL" />. 
6. Copy and paste the URL in a location that is accessible since the URL is required to set up the Salesforce.com 

connection in Tenrox. For more information, see Setting Up the Connection to Salesforce.
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Setting Up the Connection to Salesforce
The connection to Salesforce.com is configured using the Tenrox application.

To set up the connection to Salesforce.com:
1. Log on to the Tenrox application.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Select Salesforce.com from the CRM System list and then click Save.
4. Click the Options button to open the CRM Integration Options page.
5. Enter the URL provided by Salesforce.com, as well as your Logon Id and Password.

6. Select an object from the Map Tenrox Project to CRM object list to map the Tenrox project to a specific 
object in Salesforce.com, such as a project, opportunity or case.

7. Enter the email address of the user who will be sent a notification in the event of an object import failure 
(case, opportunity, project, client, user or contact).

8. Select the Automatically import Contacts check box to automatically import a client’s associated contacts 
when the accounts are imported from Salesforce.com to Tenrox.

9. Select the Automatically import Projects check box to automatically import all projects, cases or 
opportunities created in Salesforce.com to Tenrox. 

10. Click the Test Connection link to verify the connection between Tenrox and Salesforce.com.
11. Click Save to save the changes.

Note: Before setting up the connection to Salesforce.com, ensure that the URL to access the 
Salesforce.com Web service is available; for more information, see Locating the URL in the 
Salesforce WSDL Document.

Note: Ensure that the URL is readily available; for more information, see Locating the URL in the 
Salesforce WSDL Document.

Available as of: Tenrox 2011 R3. To track specific Salesforce.com objects as projects in the Tenrox, users 
can now map projects, opportunities and cases in Salesforce to projects in Tenrox. 

Available as of: Tenrox 2011 R3. In the event a data error (not a failure of the import service) occurs 
during the import process, the information displayed in the Import Status grid is emailed to 
the email address defined in the Failure notification email box. The default email format 
can be viewed by clicking Setup>Organization>System, then the System Setup and Email 
Templates buttons to access the CRM Notification link.

Note: If the check boxes for automatically importing the contacts and the projects are not selected, the 
contacts associated with the client, as well as the projects, cases or opportunities created in 
Salesforce.com, are not automatically imported to Tenrox when the CRM Users and Contacts 
Import and CRM Data Exchange services are running. For more information on automation, see 
Setting Up the Automated (Batch) Processing.



© 2016 Tenrox. All rights reserved. 17

Mapping the Objects Between Salesforce and Tenrox

Mapping the Objects Between Salesforce and Tenrox 
After the Salesforce.com connection is set up, the system automatically maps certain imported objects from 
Salesforce.com to objects existing in Tenrox by default. The mapping of objects between Salesforce.com and Tenrox 
ensures that the information is transferred properly and reliably during the import and export processes. For 
information on custom integrations and importing cases, opportunities and projects with their associated detail 
objects, see Setting the Advanced Integration Options.

The mapping of CRM Users to Tenrox Users serves as an example of how fields are mapped between Salesforce.com 
and Tenrox objects since the mapping of the fields between the Salesforce.com and Tenrox objects is similar for the 
other objects, which include the following:

 CRM Accounts to Tenrox Clients 

 CRM Contacts to Tenrox Contacts 

 CRM Projects to Tenrox Projects 

 Tenrox KPIs to CRM Opportunity 

Deprecated as of: Tenrox 2011 R3. The Project Manager, Phase and Priority fields are removed from the 
project mapping options and are now mapped using the post update triggers; for more 
information, see Defining the Custom Integration Settings.
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To map the CRM Users to the Tenrox Users:
1. Log on to Tenrox.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page.
3. Click the Options button to open the CRM Integration Options page.

4. Click the Mapping tab and then the CRM Users to Tenrox Users link to open the Map User Fields page. 

5. Click the Copy and Associate icon to create the user-defined fields in Tenrox and associate them to the Tenrox 
Users profile. 

6. Verify that the appropriate Tenrox field is specified and assign a tab for each Salesforce.com field; for more 
information on mapping, see the table Mapping Fields Between Salesforce and Tenrox. 

7. Click the User Defined Fields link to map specific fields as user-defined fields, as well as view a list of all user-
defined fields created under each tab for the Tenrox User profile.

8. Click Save to save the changes and then click the Back link.

Note: Ensure that the Salesforce.com connection is set up; for more information, see Setting Up the 
Connection to Salesforce.

Note: The Map User Fields page lists the fields that can be imported to the Tenrox Users profile. The Map 
Client Fields page (CRM Accounts to Tenrox Clients) and Map Project Fields page (CRM Projects to 
Tenrox Projects) includes a Creation Options section to allow users to create and save the names of 
placeholders for the clients and projects. 

Note: When the Copy and Associate icon is gray ( ), the field exists in the Tenrox Users profile and is 

already mapped. When the Copy and Associate icon is blue ( ), the entry does not exist in the 
Tenrox Users profile and is not mapped. If a user-defined field with the same name and type already 
exists in Tenrox, then the system automatically maps the imported Salesforce.com field to the 
existing user-defined field.

Note: The User Defined Fields Tab column displays the tab under which the Salesforce.com field appears. 
To verify that the field is displayed under the assigned tab, click Setup>Organization>Users and 
select a user from the list to open the User Edit page, then click the specified tab to view the field.
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Mapping the Objects Between Salesforce and Tenrox
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Mapping the Tenrox KPIs to the Salesforce Fields
Tenrox provides Key Performance Indicators (KPIs) help companies monitor the efficiency of their projects and 
employees against operational targets. The Tenrox KPIs track and transfer specific project-related information from 
Tenrox to Salesforce.com using a set of KPI fields. 

To map the Tenrox KPIs to the Salesforce fields:
1. Log on to Tenrox.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page.

4. Click the Mapping tab and then click the Tenrox KPIs to CRM Opportunity link to open the 
Map Tenrox KPI Fields page that displays a list of fields that can be mapped between the Salesforce.com and 
Tenrox.

5. Select the corresponding Salesforce.com field from the CRM Fields list for each of the Tenrox KPI fields that 
you want to map. 

6. Click the Back link when the required fields are mapped between the Tenrox and Salesforce.com. 

Note: Since all updates to the KPI fields originate in Tenrox, Tenrox is the primary application (master). 
The information between Salesforce.com and Tenrox is synchronized through the Automation 
Processing options; for more information on automation, see Setting Up the Automated (Batch) 
Processing.

Note: Ensure that the Salesforce.com connection is set up; for more information, see Setting Up the 
Connection to Salesforce.

Note: The CRM Fields lists are filtered based on the data type of the corresponding Tenrox field.

Note: After the fields are mapped, the information is transferred to Salesforce projects when the 
Automation Processing options are scheduled to run; for more information, see Setting Up the 
Automated (Batch) Processing.
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Importing the Users and Contacts into Tenrox

Importing the Users and Contacts into Tenrox
The users and contacts can be manually imported from Salesforce.com into Tenrox from the Tools menu. 

To import the users and contacts into Tenrox:
1. Click Tools>Import>CRM.

2. Under Import List Selection, select the Users and Contacts check boxes to import the users and contacts 
respectively from Salesforce.com into Tenrox.

3. Click the Import using service or the Import link to start the import process. 

4. Click the Cancel link to cancel an import process that is not in progress. 

5. Click the Logs link to display the following information:

 Type: message type, options include Error or Message 

 CRM Object: type and name of object imported from Salesforce.com

 Imp/Exp: type of activity performed, options include Import or Export 

 Results: type and name of the object created in Tenrox

 Date/Time: date and time of import 

 Source: name of the user who performed the import from Tenrox

6. Click Setup>Work>Clients and a client from the list to open the Client Edit page, then click the Contacts 
button to open the Contact List page that displays a list of the imported contacts.

7. Click Setup>Organization>Users to open the Users page that displays a list of the imported users. By default, 
the Standard User security profile is assigned to all users imported from Salesforce.com.

Note: If Salesforce contacts are not associated to any Salesforce.com accounts already imported to 
Tenrox, then they are not imported.

Note: The Import using service option allows users to access other pages while the import process is in 
progress. The Import option forces an immediate import and does not allow users to access other 
pages while the import process is in progress.

Note: An import process cannot be cancelled once it is in progress.

Note: To delete all message logs, click the Clear Logs link and then click the Back link to return to Import 
List Selection page. 
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Setting Up the Automated (Batch) Processing 
The CRM automation processing options are used to automatically update information between Salesforce.com and 
Tenrox. Setting up automated processing for Salesforce.com and Tenrox integration ensures that the information is 
synchronized in both systems. 

From the Automation Processing Options page, the following CRM services are available:

 CRM Data Exchange service that is set to automate the following:

 Update Project, User and Contact data from Salesforce.com to Tenrox

 Update KPIs from Tenrox to Salesforce.com

 Import Projects from Salesforce.com to Tenrox

 CRM Users and Contacts Import service that is set to automate the import of users and contacts from 
Salesforce.com to Tenrox 

Note: If information updated directly in Tenrox differs from the information in Salesforce.com, then it is 
overwritten on the next import from Salesforce.com. 

Note: To automate the processing of the CRM Users and Contacts Import and CRM Data Exchange 
services, ensure that the check boxes for automatically importing the contacts and projects are 
selected. For more information, see Setting Up the Connection to Salesforce.
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To set up the automated processing options:
1. Click Setup>Organization>System and then click the Automation button to open the Automation Processing 

Options page.

2. Click the Enable Automation Processing check box to enable the automatic processing feature.
3. Click the CRM Data Exchange and CRM Users and Contacts Import check boxes to enable the services or click 

each service to open the Automation Service Setup page to edit the following:

 Start Date: start date of processing; set by default to the date when batch service was initialized 

 Start Time: time the service starts the processing; set by default to 01:00 

 End Date: end date of processing; set by default to Open Ended 

 End Time: time the service stops the processing; set by default to 01:00 

 Time Zone: time zone of processing time; set by default to the server time zone 

 Process Every: frequency service is processed; set by default to one day

 Last Process: date and time of the last automated background process 

 Status: status of the process (successful or unsuccessful)

 Enable Service: select the check box to enable the service; check box is cleared by default (disabled)

 Description: description of the process

4. Click the Save link to save the changes and then the Back link to return to the Automation Processing Options 
page.

5. Click the Save link to save the changes and then the Back link to return to the System page.

Note: When the Add to Automation service check box is selected, the Process Every option defines the 
time interval for mapping the objects. When the Add to Automation service check box is cleared, 
the Process Every option is not available. For more information, see Defining the Tenrox Object 
Mapping Fields.
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Exporting the Projects from Salesforce into Tenrox
The Salesforce cases, opportunities and projects are exported to Tenrox as projects. For more information on 
exporting, see the following:

 Creating the Projects in Salesforce

 Exporting the Projects into Tenrox

 Viewing the Reports

 Setting the Advanced Integration Options

Creating the Projects in Salesforce
Before a project can be exported (published) from Salesforce.com to Tenrox, it is first created in Salesforce.com.

To create the projects in Salesforce:
1. Log on to Salesforce.com. 

2. Click Setup at the top of the page to open the Personal Setup page.
3. Click the Project link/tab to open the Project page.
4. Click the New button to open the Project Edit page.

5. Enter the required information to create the record and then click the Save button to display the project 
details for the newly created record.

6. Click the Edit button to modify the project and then click Save to save the changes.
7. Click the Delete button and then click OK when prompted to confirm the deletion of the project.
8. Click the Open/Publish Project button to export the project from Salesforce to Tenrox. 
9. Click the Milestone button to access a project’s milestones in the Tenrox application 

(Setup>Work>Projects>Project Edit).

10. Click the Tenrox Portal button to automatically launch the Tenrox application.

Note: The mandatory fields are marked with vertical red bar.

Note: The milestones are not available until a project is published.
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Exporting the Projects into Tenrox 
Before exporting projects from Salesforce.com into Tenrox, ensure the that projects are associated to the 
Salesforce.com accounts and a custom link is created and associated to the projects in Salesforce.com. When 
Salesforce.com projects are exported to Tenrox, the accounts associated to them are automatically exported. The 
following rules apply when exporting Salesforce accounts to Tenrox:

 If an account is deleted in Salesforce.com that has associated entries in Tenrox, then it cannot be deleted in 
Tenrox; however, if the account does not have any associated entries in Tenrox, then it can be deleted in 
Tenrox using the Automation Processing options

 If the name of an account, which already exists as a client in Tenrox, is updated in Salesforce.com, the Tenrox 
client name will be updated

 If a Tenrox client has the same name as the Salesorce.com account, then the Tenrox client (account) is 
overwritten during the export process by the Salesforce.com account

 Updates to Tenrox occur when the Automation runs.

To export the projects from Salesforce.com into Tenrox:
1. Log on to Salesforce.com. 

2. From the user menu, click Setup to open the Personal Setup page.
3. Click the Project link/tab to open the Project page.
4. Click the project that you want to export and then click the Open/Publish Project button to display the 

Salesforce project name in the Project Edit page. 

Viewing the Reports
After a project is exported to Tenrox, the following reports can be viewed:

 Project Status Report: displays the general project details, such as the name of the project, associated client 
name, start and end date, status (active or inactive), financial information, forecasts, and milestones related 
to the project

 Utilization reports: display the total number of actual hours and actual billable hours logged against the 
project; if a resource plan is set for the project, then the forecasted hours and forecasted billable hour 
information is also displayed

 Utilization Summary: information is grouped by project, resources, weeks and days of the week

 Utilization By Month: information is grouped by project, resources and months

 Utilization by Week: information is grouped by project, resources and weeks

Note: This rule also applies to exported projects, users, and contacts.

Note: Provided that there is an Integration ID for the given Tenrox client, the client name will be updated 
to reflect the account name change made in Salesforce

Note:

 Salesforce acounts are referred to as clients in Tenrox.

 When a project is exported, the associated account and owner (as user) is automatically exported 
to Tenrox. However, the associated contacts for the account are only exported if the 
Import Contacts option is selected; for more information, see Setting Up the Connection to 
Salesforce.

Note: If a project is not exported, the message the Project does not exist is displayed. If the Salesforce 
user does not exist in Tenrox when the Open/Publish Project button is clicked, then the user is 
required to log on to the Tenrox application using a Logon name and Password.
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To view the reports:
1. Log on to Salesforce.com. 

2. From the user menu, click Setup to open the Personal Setup page.
3. Click the Project link/tab to open the Project page.
4. Click a project and then click the report that you want to view for the selected project.

Note: If the Salesforce user does not exist in Tenrox when a report is clicked, then the user is required to 
log on to the Tenrox application using a Logon name and Password.
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Setting the Advanced Integration Options

The Advanced Options page is used to define the conditions for importing, updating and deleting the objects, as 
well as setting the pre- and post-processes to trigger the successful import, update or deletion of objects. For more 
information, see the following:

 Defining the Custom Integration Settings

 Mapping Existing Objects in Tenrox to Objects in Salesforce

 Defining the Tenrox Object Mapping Fields

 Mapping the Tenrox and Salesforce Object Fields

 Verifying the Status of the Imports

 Deleting or Synchronizing the Tenrox Object Mapping Entries

 Importing the Project Related Objects into the Tenrox Database

Available as of: Tenrox 2011 R3

Note: The term object can refer to any project, opportunity or case.
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Defining the Custom Integration Settings 

From the Advanced Options page, users can perform the following:

 Define the custom filters to apply conditions to the filter queries for the Salesforce.com objects that are 
imported, updated or deleted in Tenrox

 Define the custom operations when importing, updating or deleting Salesforce objects

 Define the project fields that need to be imported from Salesforce.com into Tenrox but cannot be mapped 
through Tenrox; the fields are used to customize functionality

To define the conditions for the custom filters:
1. Log on to the Tenrox application.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page and then click the Advanced Options link 

to add or edit the user-defined queries in the system defined statement boxes. 

 Import filter logic: allows users to specify which objects are imported

 Update filter logic: allows users to specify which objects are updated

 Delete filter logic: allows users to specify which objects are deleted

4. Click the Validate query link to run the query on Salesforce.com.

 If the query syntax is valid, the query returns the number of records for the import and update filters

 If the query syntax is not valid, the query is not processed and an error message is displayed for the import 
and update filters

 If no query is defined for the delete filter, no projects are deleted and an error message is displayed

5. Click the Copy to clipboard link to copy the query to the clipboard and paste it into an editor, such as Apex 
Explorer, to correct syntax errors.

6. Define the stored procedures that trigger the custom functions performed before or after the Salesforce 
objects are imported, updated or deleted in Tenrox.

 Execute before delete: defines the stored procedure that is triggered before a deletion occurs; it runs on 
every project marked for deletion

 Execute after create: defines the stored procedure that is triggered after a creation occurs; it runs on 
every newly imported project

Available as of: Tenrox 2011 R3

Note: The filter conditions are applied only to the Salesforce objects that are imported through the 
automation service; for more information, see Setting Up the Automated (Batch) Processing. The 
customization of the filters allows users to display only the relevant data for the projects imported 
into Tenrox; for example, importing projects linked to Salesforce.com opportunities marked as 
Closed - Won.

Note: A system defined statement is available for each filter. The system defined statement is followed by 
a user-defined query that is used to filter the list of projects that are imported, updated or deleted 
in Tenrox. 

Note: The format of a user-defined query is set as an SQL statement. The user-defined query is used only 
with the automation service since objects manually pushed from Salesforce.com do not need to 
meet the filter conditions to be successfully imported into Tenrox.

Note: When a project is deleted, the project, case or opportunity is set to TROXUniqueid = “” and since 
the default condition of the Import filter logic is to import any projects, cases or opportunities with 
TROXUniqueid = “”, a user-defined condition needs is defined for the Import filter logic to prevent 
deleted projects from being re-imported.
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 Execute before update: defines the stored procedure that is triggered before the actual updates occur to 
the project; occurs before the Execute after update procedure

 Execute after update: defines the stored procedure that is triggered after an update successfully 
completes 

7. Enter a list of project fields, separated by a comma, that should be imported from Salesforce.com to Tenrox 
but cannot be mapped through Tenrox in the Use this area to add fields to the returned query (separate 
fields by comma) box. 

8. Click the Save link to save the changes.

9. Click the Linked Object Import link to select the objects related to the specific project being imported; for 
more information, see Importing the Project Related Objects into the Tenrox Database.

10. Click the Tenrox Object Mapping link to select the information imported into the Tenrox; for more 
information, see Defining the Tenrox Object Mapping Fields.

11. Click the Import Status link to view the status of the imported objects; for more information, see Verifying the 
Status of the Imports. 

Note: The pre- and post-processing run the stored procedures when an action is carried out by the 
automation service; for example, creating a task for a specific work type after a project is 
imported. The stored procedures only affect objects that are imported, updated or deleted through 
the automation service in Tenrox or pushed out of Salesforce.

Note: The project fields are imported when a project is created or updated through the automation 
service or the object is manually pushed from Salesforce.com to Tenrox. The fields are stored in the 
Tenrox database but are not mapped in Tenrox. When the project is deleted in Tenrox, the fields 
are also deleted from the database.

Note: When the filter logic statements are saved, the syntax of the queries is validated. If an error is 
encountered for a given filter, a message displays that the syntax of the filter is invalid and to 
validate the syntax for proper integration.

Note: Since fields cannot be specific for the selected objects, all the fields associated with the objects are 
imported.

Note: The information imported into Tenrox can include objects or scripts returning data from the 
database.
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Mapping Existing Objects in Tenrox to Objects in Salesforce

The ability to update existing objects in Tenrox when importing from Salesforce.com offers users the flexibility to 
map existing objects in Tenrox to objects in Salesforce to automatically update data across the applications. When 
importing objects from Salesforce.com into Tenrox, Tenrox verifies if specific objects already exist from imports or 
manual entries to avoid duplication. If the imported object already exists in Tenrox, then the Tenrox fields are 
updated. If the imported object does not already exist in Tenrox, then it is created. 

To determine if the objects being imported from Salesforce.com already exist in Tenrox, the integration process 
verifies if certain key fields have matching values or entries; for more information, see Mapping the Tenrox and 
Salesforce Object Fields. To be considered the same object, the table Mapping Fields Between Salesforce and 
Tenrox lists the primary mapped fields that must have the same values or entries between both systems. 

For example, a Salesforce (CRM) User and a Tenrox User map to the Username and Logon Name fields respectively. 
Therefore, if a user with the Username daniel@tenrox.com is imported from Salesforce.com and a user with the 
Logon Name daniel@tenrox.com already exists in Tenrox, then a new user is not created but rather the 
daniel@tenrox.com related fields for the Tenrox user are updated with the Salesforce.com user details.

For more information on mapping objects, see the following:

 Defining the Tenrox Object Mapping Fields

 Mapping the Tenrox and Salesforce Object Fields

Available as of: Tenrox 2011 R3

Note: In earlier releases, when importing from Salesforce, the import process failed when trying to import 
objects that already exist in Tenrox.
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Mapping Fields Between Salesforce and Tenrox 

Salesforce (CRM) Tenrox 

Object  Field Object  Field

User Username User Logon Name

Account Account Name Client Name

Contact First Name, Last Name Client 
Contact

First Name, Last Name

Project Name Project Name

Opportunity Opportunity Name Name

Case Case Number Name

Available as of: Tenrox 2011 R3, a project, opportunity or case can be any object associated to the Tenrox 
project object.
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Defining the Tenrox Object Mapping Fields

The Tenrox Object Mapping page is used to define the Tenrox data and related fields that are mapped to objects in 
Salesforce.com. The ability to map Tenrox data to the Saleforce.com object fields makes the information available 
to users in Salesforce.com. The additional fields defined in the Tenrox database are mapped to fields in 
Salesforce.com but are not available through the user interface. For more information, see Importing the Project 
Related Objects into the Tenrox Database.

To define the Tenrox object mapping entries:
1. Log on to the Tenrox application. 

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page.
4. Click the Advanced Options link and then the Tenrox Object Mapping link to display the created object 

mapping entries; by default, the grid is empty. The following information is displayed for each entry: 

 Name: user-defined name of the Tenrox object mapped entry displayed in the Synchronization Name box

 Tenrox Query: name of the Tenrox stored procedure

 CRM Object: object name as it appears in Salesforce.com 

5. Click the New link to create a new entry or click an entry from the grid to edit an existing entry. Any created 
Tenrox object mapping entries are displayed in the grid.

 Synchronization Name: user-defined name for a Tenrox object mapping entry

 Tenrox Query: name of the stored procedure run when the entry synchronizes with Salesforce.com

 CRM Object: lists the available Salesforce objects for mapping the Tenrox object to a related object upon 
synchronization

 Synchronization Type: defines whether the Tenrox object is created and updated (default) or only updated 
upon synchronization; for example, if users wants to map Tenrox invoices to CRM opportunities that already 
exist in Salesforce.com, then the opportunities would only be updated not recreated 

 Add to Automation service: defines whether or not the process is added to the automation service with the 
automation service default values; for more information, see Setting Up the Automated (Batch) Processing

 Delete CRM object if object no longer returned by the Tenrox query: defines whether or not any record 
not returned by the Tenrox query is deleted in Salesforce.com

 Description: user-defined description for the object mapping 

6. Click the Save link to save the changes.
7. Click the Synchronize link and then click Yes to confirm the export of the Tenrox data to the selected 

Salesforce object.

8. Click the Export Status link to view the status of the selected object. For more information, see Verifying the 
Status of the Imports and Deleting or Synchronizing the Tenrox Object Mapping Entries.

Available as of: Tenrox 2011 R3

Note: For synchronization to work, the stored procedure has to exist in the Tenrox database. If a stored 
procedure defined for the Tenrox query does not exist in the database, the user is prompted to 
enter a valid stored procedure name before proceeding; for more information, see Defining the 
Custom Integration Settings.

Note: The Synchronize link is unavailable if no Tenrox object mapping entries are selected.
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Mapping the Tenrox and Salesforce Object Fields

The Map Objects page is used to define the mapping between the fields returned by the Tenrox query and the fields 
of the selected Salesforce.com object. With Tenrox object mapping, users can map any Tenrox object to a 
Salesforce object, as long as a stored procedure is defined. For more information on defining stored procedures, see 
Defining the Custom Integration Settings.

To map the Tenrox and Salesforce object fields:
1. Log on to the Tenrox application.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page.
4. Click the Advanced Options link and then the Tenrox Object Mapping link to display the created object 

entries in the grid.
5. Click the name of a Tenrox object mapping entry and then click the Map Fields link to map the Tenrox and 

Salesforce.com fields. 

6. Under CRM Fields, select a field to map the selected Salesforce.com object to the corresponding Tenrox field; 
by default, each box is set to Please Select. The fields displayed in the CRM Fields boxes depend on the 
selected Salesforce object; for more information, see Defining the Tenrox Object Mapping Fields.

7. Select the Key Field check box to define the related Tenrox and Salesforce.com field used as the unique 
identifier for the mapping. 

8. Click the Save link to save the changes and then the Back link.

Available as of: As of Tenrox 2011 R3

Note: The Tenrox Fields (read-only) list each field returned by the Tenrox query as defined in the Tenrox 
stored procedure; for more information on stored procedures, see Defining the Custom Integration 
Settings

Note: This Key Field is a unique marker that represents the objects in both Tenrox and Salesforce.com. 
Only one field can be selected as a Key Field.

Note: If more than one field is selected as a Key Field, the changes are not saved and a message indicates 
that only a single Key Field can be defined. Also, at least one field mapping and one Key Field 
needs to be defined; otherwise, the changes are not saved.
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Verifying the Status of the Imports 

The status of the last synchronization process performed for each object can be viewed from the Import Status and 
Export Status pages. The Import Status page displays the latest import status of all projects created, updated and 
deleted based on the custom defined filters and processes. The Export Status page displays the latest import status 
of all Tenrox object mapping entries.

To view the status of the synchronized objects:
1. Click the Import Status or Export Status link to view the status of last synchronization event. For more 

information on accessing the Import Status link, see Defining the Custom Integration Settings. For more 
information on accessing the Export Status link, see Defining the Tenrox Object Mapping Fields.

2. Verify the synchronization status of a specific object or objects. 
3. Enter the filter criteria or use wildcards in the boxes to display only the objects that match the filter criteria. 

 From the Import Status page, the objects can be filtered using the following criteria:

 Name: name of Salesforce.com object that is synchronized

 Date: date and time of the last update

 Status: status of last update, options include Success or Failure 

 CRM Object Id: identification of Salesforce.com object that was updated

 Message: error message describing an encountered failure condition

 Updated by: name of user who performed the last update; if the update is performed by the automation 
service, Automation Service is displayed

 From the Export Status page, the objects can be filtered using the following criteria:

 Name: name of Tenrox object mapping entry 

 Date: date and time of the last update

 Status: status of last update, options include Success or Failure 

 CRM Object Id: identification of Salesforce.com object that was updated

 Data: data that was synchronized

 Message: error message describing an encountered failure condition

 Updated by: name of user who performed the last update; if the update is performed by the automation 
service, Automation Service is displayed

4. Click the Back link to exit the status page.

Available as of: Tenrox 2011 R3

Note: The Import Status link is also available from the General tab on Project Edit page as long as the 
projects are imported, updated or deleted using the custom integration settings defined on the 
Advanced Options page and the CRM integration licenses exist. For more information, see Defining 
the Custom Integration Settings.

Note: The CRM Object Id can be appended to the Salesforce.com URL to access the object.

Note: In the event a data error is encountered during the import, the information in the Import Status grid 
is emailed to the email address defined in the Failure notification email box. The default email 
format, can be viewed by clicking Setup>Organization>System and then the System Setup and 
Email Templates buttons to access the CRM Notification link.

Note: The CRM Object Id can be appended to the Salesforce.com URL to access the object.
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Deleting or Synchronizing the Tenrox Object Mapping Entries

The Tenrox Object Mapping page lists all the created Tenrox object mapping entries. From the Tenrox Object 
Mapping page, users perform the following

 Create the entries; for more information, see Defining the Tenrox Object Mapping Fields 

 Delete existing entries

 Synchronize the entries

 View the status of the Tenrox object mapping entries; for more information, see Verifying the Status of the 
Imports

To delete or synchronize the Tenrox object mapping entries:
1. Log on to the Tenrox application.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page.
4. Click the Advanced Options link and then the Tenrox Object Mapping link to display the created object 

entries in the grid. 
5. Select the check boxes of the existing object entries that you want to delete or synchronize.
6. Click the Delete link and then Yes to confirm the deletion of the selected entries or click the Synchronize link 

and then Yes to confirm the export of the selected entries to Salesforce.com. 

Available as of: Tenrox 2011 R3

Note: The Delete and Synchronize links are unavailable if no Tenrox object mapping entries are selected.
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Importing the Project Related Objects into the Tenrox Database

The Linked Object Import page is used to import into the Tenrox database all fields related to a specific object 
associated with an opportunity, case or project in Salesforce.com. For example, to create tasks with services (work 
types) associated to projects in the sales process, users import the associated items for a project so that they can 
run a script in the post-processing.

 Objects are imported with all their properties when their values are updated in Salesforce

 Objects are imported through the automation service or manually pushed from Salesforce to Tenrox

 Objects are stored in the Tenrox database but are not available through the user interface

 Objects can later be used by the pre- and post-processing stored procedures

Available as of: Tenrox 2011 R3

Note: The mapped object fields are not displayed in Tenrox but rather stored in the Tenrox database. For 
example, the Salesforce.com opportunity has an associated object named Note that includes the 
fields Name and Text. When Note is selected and the opportunity is either imported or updated, the 
associated object (Note), as well as the related fields (Name and Text) are also imported into the 
Tenrox database. Therefore, all the fields associated with this object are imported.
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To import the project related objects into the Tenrox database:
1. Log on to the Tenrox application.

2. Click Setup>Organization>System and then click the CRM button to open the CRM Integration page. 
3. Click the Options button to open the CRM Integration Options page.
4. Click the Advanced Options link and then the Linked Object Import link to display all the Salesforce.com 

objects that are associated to an opportunity, case or project. 
5. Select the check boxes of the Salesforce.com objects in the Available CRM Objects pane and then add them to 

the Selected CRM Objects pane to import and save the object fields in the Tenrox database during the import 
or update process.

6. Click the Back link to return to the Advanced Options page.

Note: The Available CRM Objects pane displays all Salesforce.com objects linked to Salesforce.com cases, 
opportunities and projects. The Selected CRM Objects pane displays the objects selected for 
import.
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